summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2023-09-08 11:19:19 -0700
committerSteve Arnold <nerdboy@gentoo.org>2023-09-08 11:19:19 -0700
commit9bf716876728169a1fc151ec3034761c124600ab (patch)
treee1db0a88ffe531b42d558f4d1ecb0529debf059d /dev-python/pystache
parentdev-db/sqlcipher: add 4.5.5 (diff)
downloadgentoo-9bf716876728169a1fc151ec3034761c124600ab.tar.gz
gentoo-9bf716876728169a1fc151ec3034761c124600ab.tar.bz2
gentoo-9bf716876728169a1fc151ec3034761c124600ab.zip
dev-python/pystache: refactor for upstream changes, add doc deps
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'dev-python/pystache')
-rw-r--r--dev-python/pystache/pystache-0.6.5.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/pystache/pystache-0.6.5.ebuild b/dev-python/pystache/pystache-0.6.5.ebuild
index c10cd9359cc2..3c70a630edb7 100644
--- a/dev-python/pystache/pystache-0.6.5.ebuild
+++ b/dev-python/pystache/pystache-0.6.5.ebuild
@@ -30,9 +30,23 @@ LICENSE="MIT"
SLOT="0"
BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/pyyaml[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
+
+distutils_enable_sphinx \
+ docs/source \
+ dev-python/sphinx-rtd-theme \
+ dev-python/recommonmark \
+ dev-python/sphinxcontrib-apidoc
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ sed -i '/sphinx_git/d' "${S}"/setup.cfg "${S}"/docs/source/conf.py
+ default
+}