summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 23:06:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 23:20:14 +0200
commit07f764be9a475e12224a8c9f0a4b6cca63586dda (patch)
tree98cdd631c61262775df2efce3cd827b88b9e610e /dev-python/pyte
parentdev-python/sphinxcontrib-bibtex: Bump to 2.4.2 (diff)
downloadgentoo-07f764be9a475e12224a8c9f0a4b6cca63586dda.tar.gz
gentoo-07f764be9a475e12224a8c9f0a4b6cca63586dda.tar.bz2
gentoo-07f764be9a475e12224a8c9f0a4b6cca63586dda.zip
dev-python/pyte: Bump to 0.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyte')
-rw-r--r--dev-python/pyte/Manifest1
-rw-r--r--dev-python/pyte/pyte-0.8.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyte/Manifest b/dev-python/pyte/Manifest
index b0b9f0bb7471..076cb42d1e8f 100644
--- a/dev-python/pyte/Manifest
+++ b/dev-python/pyte/Manifest
@@ -1 +1,2 @@
DIST pyte-0.8.0.tar.gz 91320 BLAKE2B b973050912c7d3b67393208a5b17f382705fe78964528e003b71addc12586353a3a9c7eeb68c224dfb945b5f9d3b52823cd254885dd5ac6901be119583a71a2e SHA512 c488fd0a61c1dc34b27e12ed9ba1109bb2c331626c982da06e7540bdd168008cb5106a17c71e60e38c493f2dd9f21ba3cf05118928744dfa192d62e511b4c4e8
+DIST pyte-0.8.1.gh.tar.gz 92220 BLAKE2B f4f803ecbf9bc62936ea499929b7fb976c14ee09fe00ee56d5499bb2543a6ac769dd7c87e177c297bbf8ab082c34f154a26daf3a1c84917249400b09556c2b80 SHA512 f49d9394cca92c27fdd5319bdce164d5cac63b77d13156de7105bee6087a615e844fafa8507089c8bf6cf31a796cc858a3ccf597aa23cfa595d0d9e0adfab5d4
diff --git a/dev-python/pyte/pyte-0.8.1.ebuild b/dev-python/pyte/pyte-0.8.1.ebuild
new file mode 100644
index 000000000000..7a8fc8d73612
--- /dev/null
+++ b/dev-python/pyte/pyte-0.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.org/project/pyte/ https://github.com/selectel/pyte"
+SRC_URI="
+ https://github.com/selectel/pyte/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # run pytest directly for tests
+ sed -i '/setup_requires=\["pytest-runner"\]/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}