summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-29 06:43:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-29 06:43:09 +0200
commit0c78fb82448addd8a83d3adce2c4a86d25845fe4 (patch)
tree5147b02857c30ba6d048dab21ad0ee22bb651712 /dev-python/pytest-check
parentdev-python/sqlglot: Bump to 25.18.0 (diff)
downloadgentoo-0c78fb82448addd8a83d3adce2c4a86d25845fe4.tar.gz
gentoo-0c78fb82448addd8a83d3adce2c4a86d25845fe4.tar.bz2
gentoo-0c78fb82448addd8a83d3adce2c4a86d25845fe4.zip
dev-python/pytest-check: Bump to 2.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-check')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/pytest-check-2.4.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
index 015937648c55..494e49b3fd84 100644
--- a/dev-python/pytest-check/Manifest
+++ b/dev-python/pytest-check/Manifest
@@ -1,2 +1,3 @@
DIST pytest_check-2.3.1.tar.gz 28674 BLAKE2B 732538aec690d121132a0594a49b77658eb8be79d6e59bacae1d13ea38e59dd3e4b55c62fc07741e08621dda271d7d2284f825770a2acef7d5b0c80c80e79beb SHA512 b4a2805b7dc3dfe9f56db6f27a9e4927de070d57bf3906f303c611021081d7b638d9ee58de744491005e10541f527f1bfddaf51be64f2def8a1190cfd1abd43a
DIST pytest_check-2.4.0.tar.gz 28965 BLAKE2B 1c87ffa59f6c2497c933822463fd20b36f1653db7fd6cf3e56e6722df4488bd2efbdd05d9251bc97f900fa49a06696c37a6186942891a5fbf3ff3a5b59fa2cb0 SHA512 68f3eb02be3a1ad68db9f7f0d5043297d708e2ac0fdeced50cd657426e307df785909a91f1bcb002cb17b3198aaa595404189c83b4ee1bca268f6a4096e5a90f
+DIST pytest_check-2.4.1.tar.gz 28933 BLAKE2B 47ab104426e9c967ba7ad82cb76663803ce55133ca868369ff466def35ad0ea64ef7872464de8184ee985cc938265f0efc586212a9e6be0b0879d955dcd29e10 SHA512 a334425d5aba77b574bcddad8d9a15ffac1638df1ab3b2aeceb4c1580a3871a36431a7d287e1cc1d272bd57b92c1f6e65c3976fdd1793935bfc357916b15b11a
diff --git a/dev-python/pytest-check/pytest-check-2.4.1.ebuild b/dev-python/pytest-check/pytest-check-2.4.1.ebuild
new file mode 100644
index 000000000000..cc8edbab54a3
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-2.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest