summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 12:20:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 12:40:42 +0200
commit4821784c526a1dab7a383bc983e97b5afe521e14 (patch)
treeddecd62a799e969b51ca798fec7427cb22cb1514 /dev-python/pytest-rerunfailures
parentdev-python/autocommand: Enable py3.11 (diff)
downloadgentoo-4821784c526a1dab7a383bc983e97b5afe521e14.tar.gz
gentoo-4821784c526a1dab7a383bc983e97b5afe521e14.tar.bz2
gentoo-4821784c526a1dab7a383bc983e97b5afe521e14.zip
dev-python/pytest-rerunfailures: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild
new file mode 100644
index 000000000000..1fc685a9c8cc
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=,xdist.plugin
+ fi
+ epytest
+}