summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-24 05:59:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-24 08:00:58 +0200
commitcb22d0ef47f5b98948276e23afd97ae530e56bf2 (patch)
tree0d6cc3d4b0ed62df2540d4f2037d070594dd988d /dev-python/pytest-shell-utilities
parentdev-python/pkginfo: Enable py3.11 (diff)
downloadgentoo-cb22d0ef47f5b98948276e23afd97ae530e56bf2.tar.gz
gentoo-cb22d0ef47f5b98948276e23afd97ae530e56bf2.tar.bz2
gentoo-cb22d0ef47f5b98948276e23afd97ae530e56bf2.zip
dev-python/pytest-shell-utilities: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest1
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.2.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
index d410c89a2001..48631fd3520f 100644
--- a/dev-python/pytest-shell-utilities/Manifest
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -1,3 +1,4 @@
DIST pytest-shell-utilities-1.0.5.tar.gz 89489 BLAKE2B 9cd7f95c9c1691e19c320378d1c2a4e147cb6fdc35ec6f3c80dc288e70416fce67b60ac86427f1ad322b2c17de3cd762e483d63076fa291b4b7d22d7a29c9e45 SHA512 395107af9eaa13ef39d01858e1674b6dedddc2cf93b9aba61316fd8d847031e1b535cc3bf4f2899dbc7828609b7d45b500aad29bb47668be6e0453ac099e99e4
DIST pytest-shell-utilities-1.1.0.tar.gz 90873 BLAKE2B e787733fe641eae1884470b9410f017ef718b2f51cff09f7de592efc88a7f39bdc442e56ade2c547476a9ec7200b027a9ca2aed168afe162c8d4d06c6aaf6c61 SHA512 965c85d73f2be082253892d36b90fa60db0e8548272e34a3531c98c537e86b4e2cff477c017762bf9e275d97504b779e7d741e982cc03b114e30cee9c4904d95
DIST pytest-shell-utilities-1.2.0.tar.gz 89881 BLAKE2B 8332f4f6b9b232cc8d17e94eef569ea7f17e14c4a97b060f84fd860de79bb5db2ebad5c239e889d2405e8be3db0d54b94a7071661eaf7065860049bcbc1e60a2 SHA512 efca390e2e3c78f82cf7888d511a1eb0e06e940259cfba146c40eeb54d5394f010497730837192c58e3b8c4cd350de54781f7ead7d3513d738eb34f81cc4d5ba
+DIST pytest-shell-utilities-1.2.1.tar.gz 89975 BLAKE2B 91d0731a2613beef6de98bf7eb61e773659a7047f44558e2ad5cb7c8071761d13f606d04ffb0ac3c6f926f539455cb2a0c2418e398d43d208a028c68bd268576 SHA512 73232844b482f973ad79f2578b434339f34c24cbb36f75ae66217fcd9d06a663d54a6bfcdf390d86d21e6d3b7386fd2f4ce9d6a4b1ce55592be62dbc89f2251f
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.2.1.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.2.1.ebuild
new file mode 100644
index 000000000000..b4d91a1e5427
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}