summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-06 10:24:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-06 11:00:38 +0100
commit507d6b955691cf113c07b8d8b53e91f571cd08d1 (patch)
tree0859384380c2e3d7b009a5f66065ebb379f911d5 /dev-python/readthedocs-sphinx-ext
parentdev-python/flask-cors: Bump to 3.0.10 (diff)
downloadgentoo-507d6b955691cf113c07b8d8b53e91f571cd08d1.tar.gz
gentoo-507d6b955691cf113c07b8d8b53e91f571cd08d1.tar.bz2
gentoo-507d6b955691cf113c07b8d8b53e91f571cd08d1.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext')
-rw-r--r--dev-python/readthedocs-sphinx-ext/Manifest1
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/Manifest b/dev-python/readthedocs-sphinx-ext/Manifest
index c6ef32d93290..c1383fc5248a 100644
--- a/dev-python/readthedocs-sphinx-ext/Manifest
+++ b/dev-python/readthedocs-sphinx-ext/Manifest
@@ -1 +1,2 @@
DIST readthedocs-sphinx-ext-2.1.1.tar.gz 10181 BLAKE2B 01ca34befd0f18bb747d7f843e0cc394e19db4fe471f2bb21617b6dbdf4c1ad9721047185561f9bfbd8f770e1fefd5b560e65d7c5e2675c1bc8d74e08252eeb1 SHA512 5594e375133477ecdc1d22a78c0d4dac73c5e8c1715f4309a9674497ef860b07e8872bb4ba471fbffacd8bd22bc49741b8df54ad9ca9bb474acd9cdee72c8969
+DIST readthedocs-sphinx-ext-2.1.2.tar.gz 11709 BLAKE2B 9386d9c849c4287a0f52ce054e33d22afed0426b5d775a03c90b7c18021f2a2a9429334dc0231ec8d28d3b4437dcf4e3faf57a0c1e46cfb4690893b96560fa3a SHA512 c1fa8a2c1b1d50aa5039c0592a0960b1162c31f58769754a7fdbe4d85557428f3e0a3a509012077210d30d79a28463ab0624855036ffb45d0977e9e0e666622a
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.2.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.2.ebuild
new file mode 100644
index 000000000000..68b9817de11a
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="https://github.com/readthedocs/readthedocs-sphinx-ext"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+PDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${PDEPEND} )"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest