summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-05 10:23:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-05 10:25:31 +0100
commit30d658185f6b88acdce3cc0224c27f9f1dfaff26 (patch)
treeb52cebb7b8313de4290bc3171bf05f1bee9bf7af /dev-python/rebulk/rebulk-3.1.0.ebuild
parentnet-misc/minissdpd: Bump to 1.5.20211105 (diff)
downloadgentoo-30d658185f6b88acdce3cc0224c27f9f1dfaff26.tar.gz
gentoo-30d658185f6b88acdce3cc0224c27f9f1dfaff26.tar.bz2
gentoo-30d658185f6b88acdce3cc0224c27f9f1dfaff26.zip
dev-python/rebulk: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rebulk/rebulk-3.1.0.ebuild')
-rw-r--r--dev-python/rebulk/rebulk-3.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rebulk/rebulk-3.1.0.ebuild b/dev-python/rebulk/rebulk-3.1.0.ebuild
new file mode 100644
index 000000000000..02e8eac73d2e
--- /dev/null
+++ b/dev-python/rebulk/rebulk-3.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library that performs advanced searches in strings"
+HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.org/project/rebulk/"
+SRC_URI="
+ https://github.com/Toilal/rebulk/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove base64-encoded zip archive with pytest.
+ rm runtests.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}