summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 16:58:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 16:58:37 +0200
commita643b49fd53102e6c41f8b2a21228dffee4138d2 (patch)
tree56440c38d50c33a531893d5d0200a7128ac4576a /dev-python/serverfiles
parentdev-python/sgmllib3k: Enable py3.12 (diff)
downloadgentoo-a643b49fd53102e6c41f8b2a21228dffee4138d2.tar.gz
gentoo-a643b49fd53102e6c41f8b2a21228dffee4138d2.tar.bz2
gentoo-a643b49fd53102e6c41f8b2a21228dffee4138d2.zip
dev-python/serverfiles: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/serverfiles')
-rw-r--r--dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild b/dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild
index 2244e2c1553d..dd8a7c188c53 100644
--- a/dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild
+++ b/dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild
@@ -4,17 +4,25 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1 pypi
DESCRIPTION="Utility for accessing HTTP server and storing files locally for reuse"
-HOMEPAGE="https://github.com/biolab/serverfiles"
+HOMEPAGE="
+ https://github.com/biolab/serverfiles/
+ https://pypi.org/project/serverfiles/
+"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND=">=dev-python/requests-2.11.1[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/requests-2.11.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest