summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-21 17:34:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-21 18:59:40 +0200
commit310a0580abf96d7ed050a289786b931a2c74055a (patch)
treebc323cabe1456a94761aa0c423cd8b8bfdb7648d /dev-python/sphinx-autoapi
parentdev-python/qiskit: Bump to 1.1.1 (diff)
downloadgentoo-310a0580abf96d7ed050a289786b931a2c74055a.tar.gz
gentoo-310a0580abf96d7ed050a289786b931a2c74055a.tar.bz2
gentoo-310a0580abf96d7ed050a289786b931a2c74055a.zip
dev-python/sphinx-autoapi: Bump to 3.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest1
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.1.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 77e89ae443e9..d293cd2d6c32 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1 +1,2 @@
DIST sphinx-autoapi-3.1.1.gh.tar.gz 67903 BLAKE2B aec809e53b2c1080a29c49f5d9916df2e9def0c2072d99dde7ee3250a9cc7a9fc2d1e3e76ad954cfc417205c9b8994dcb7d0533f5994eb2a584d8ffa3ee3260e SHA512 c5a3db4f6e3969af8f8f2933822e577d3469c649f6976327e55c449cd6992274ee896a7ad01d5a3bfab378819bd4fe319b9f08e989214c00b4844c03c56ed2c8
+DIST sphinx-autoapi-3.1.2.gh.tar.gz 68260 BLAKE2B 31315fb298f7dae78c10f839e2738340eaf68d5497f22368c50f14309a564d1c5636015a715a9f99080a4f753416a10c63147e63dfcd53a27d7466ad422f95c4 SHA512 18e4a49e831446fa14278ffda4fec703f3b2c86654ce78fa7f4b89e5a41f1e6b19ea76cb64e7290a3125dc027a2de8aa052495a8bfd4bcc1828780f762e81957
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.2.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.2.ebuild
new file mode 100644
index 000000000000..9182b8aa4e2c
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}