summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 12:14:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 12:34:09 +0200
commitbdda3ccc1062784551e18e4967c8730f6ff33d27 (patch)
treec405e64599786bda824256ead5e6e09e6d40a3a6 /dev-python/tenacity
parentdev-python/typeguard: Remove old (diff)
downloadgentoo-bdda3ccc1062784551e18e4967c8730f6ff33d27.tar.gz
gentoo-bdda3ccc1062784551e18e4967c8730f6ff33d27.tar.bz2
gentoo-bdda3ccc1062784551e18e4967c8730f6ff33d27.zip
dev-python/tenacity: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/tenacity-8.0.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tenacity/tenacity-8.0.1-r1.ebuild b/dev-python/tenacity/tenacity-8.0.1-r1.ebuild
new file mode 100644
index 000000000000..248a72c6338e
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.0.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ if ! has_version "dev-python/typeguard[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
+ )
+ fi
+
+ epytest
+}