summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-30 17:00:23 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-30 17:00:59 +0100
commit6eac1347c3ad867fd5930a400575fa25778e2f30 (patch)
tree78d496f1a2be21b4a5e509c0131a83f602513b50 /dev-python/thunarx-python
parentsys-apps/paludis: Drop old (diff)
downloadgentoo-6eac1347c3ad867fd5930a400575fa25778e2f30.tar.gz
gentoo-6eac1347c3ad867fd5930a400575fa25778e2f30.tar.bz2
gentoo-6eac1347c3ad867fd5930a400575fa25778e2f30.zip
dev-python/thunarx-python: Bump to 0.4.0 (masked)
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/Manifest3
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.4.0.ebuild33
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/thunarx-python/Manifest b/dev-python/thunarx-python/Manifest
index 9832d0950476..0460cf4c0450 100644
--- a/dev-python/thunarx-python/Manifest
+++ b/dev-python/thunarx-python/Manifest
@@ -1 +1,2 @@
-DIST thunarx-python-0.3.0.tar.bz2 303035 SHA256 5650e045565af82f3a5f67bbecb46182b502a37f94d08c23adac697dbb4ce258 SHA512 9be3e8b50cd668e0b63fbf54da5dec3685dde40528067b35bd1cfa87db7e037962baafce3059818a7de76101472a2b07ae209c590f2f143dbc71646e8addb28f WHIRLPOOL cfcf986b7ca9bc2fd50d4d5bbb80c6df7ac557e3ca15703eada5c71a302d4275cee7972d13cb3d746e064caeb9e90f366819045bc109d761bcc898ce5a70d577
+DIST thunarx-python-0.3.0.tar.bz2 303035 BLAKE2B af0193a3bc97c859ba98f52c612d5af81c5b7a0d8142a8283cf2b308fa183ac57ac1a2163cd882749b6fd33e0529f20f1f9e2db2dcc1aed26cb40cd5995780fb SHA512 9be3e8b50cd668e0b63fbf54da5dec3685dde40528067b35bd1cfa87db7e037962baafce3059818a7de76101472a2b07ae209c590f2f143dbc71646e8addb28f
+DIST thunarx-python-0.4.0.tar.bz2 332620 BLAKE2B 768a2a236e12d298efb3abc86f4a339548248f5f88366ec7d956249c028474612b15c340976ac2c2ced806a89517278c70b50069d76b2eee6af6dd097789e275 SHA512 fb54f83c11857ec2236a249895954efc29446120c192b8d19794b7e8145836969f87d1efa524bfaa4c9d31ee08a2c17a57d7210ce4a3a4982780d128839d02b1
diff --git a/dev-python/thunarx-python/thunarx-python-0.4.0.ebuild b/dev-python/thunarx-python/thunarx-python-0.4.0.ebuild
new file mode 100644
index 000000000000..5f2803170adc
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/glib-2.30:2
+ >=dev-python/pygobject-3.20:3[${PYTHON_USEDEP}]
+ >=xfce-base/thunar-1.7.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}