summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-10 11:36:34 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-10 11:36:54 +0100
commit42f25a2328026a029d36b4eb865a7db59f021da1 (patch)
tree91e13ed5f16fcabafbb061cf84d6e22dc13e82d5 /dev-vcs
parentdev-vcs/pre-commit: add 3.7.0 (diff)
downloadgentoo-42f25a2328026a029d36b4eb865a7db59f021da1.tar.gz
gentoo-42f25a2328026a029d36b4eb865a7db59f021da1.tar.bz2
gentoo-42f25a2328026a029d36b4eb865a7db59f021da1.zip
dev-vcs/pre-commit: drop 3.3.3, 3.5.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.3.3.ebuild60
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.5.0.ebuild61
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index f83c1b4df88d..9475fcf6da6f 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,4 +1,2 @@
-DIST pre-commit-3.3.3.gh.tar.gz 267281 BLAKE2B dbe3b90dd3808d24084ede3e9bd76ddc5b070d43bd70b3fa813f8e8e95875a178b86632208463c50a3d68868f2dd9d888e00e7bf3aeba3f3b78c7cd39b514270 SHA512 d126bead7ffa2c72213a894c82bc45d0bce8b508cf7190e7b7d56c667b5d3ebff80eedf7ecb4bb1e01923ef9a43878b73356fda866614d8cbcc8f241ee9e01f7
-DIST pre-commit-3.5.0.gh.tar.gz 268906 BLAKE2B 7585aae950f63845cf132b3472662f19f87942b886687551fbf69e4adb20513304d2c4d399c12619e6c7f9aeab0a6a57c3fe3cd271a29470bedc9480b3b34256 SHA512 c7504fa2d3ba70def3361af0fcc2f7a5454325125e27f44fbaa60906f1ac35b0fa1b646eaf326cb04d4d042ecb6786fbb8e9166099df1e687fa2a64a8113c244
DIST pre-commit-3.6.0.gh.tar.gz 268891 BLAKE2B 42c52bcd320defe877fdce51af972e177e26956c2baba5e04e9441d7a99fcdc6467dc7913b21f9300efe9ca821c7d06c8d972f3fb79f10f2212dbecb3299040a SHA512 4997dfe15d262b8d0c6de711b2543162fffe14f24ce41d3a3ba2014354861ef72eb3a9cc115125ed57ef3c25a12886f858189d684d343252ad8f46cc0c364935
DIST pre-commit-3.7.0.gh.tar.gz 269999 BLAKE2B 9ca1b2279e1ed753a09c3da83f6de19fc9b36821ba6f642962b9be1da29894e3260c48a2cdb582eb5331543fa6c7e9065d799fde7ab4e84dd54032c2ff84e4a7 SHA512 2a238e74ce2f080914e4403b7ce7b8dbd2a257a736d8292e2ec299c8015d3c4611e51f4be1a95ff2bd29db4888f6997e335346931567e943a8b5d78be7c14725
diff --git a/dev-vcs/pre-commit/pre-commit-3.3.3.ebuild b/dev-vcs/pre-commit/pre-commit-3.3.3.ebuild
deleted file mode 100644
index 754a0991d794..000000000000
--- a/dev-vcs/pre-commit/pre-commit-3.3.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~hppa ~ppc ~ppc64 x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
- ')"
-# coreutils requirement: see Bug #885559
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
- sys-apps/coreutils[-multicall]
-)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
-)
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-EPYTEST_DESELECT=(
- # All of these require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
- # and while some of them do include "skip if not found" logic, most of them do not.
- tests/languages/
- tests/repository_test.py
- # These three consistently fail with
- # Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
- # including with the sandbox disabled.
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_hook_stage_migration
- tests/main_test.py::test_try_repo
- # These two fail if pre-commit is already installed (Bug #894502)
- tests/commands/install_uninstall_test.py::test_environment_not_sourced
- tests/commands/install_uninstall_test.py::test_installed_from_venv
-)
-
-distutils_enable_tests pytest
diff --git a/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
deleted file mode 100644
index 96ec1f982805..000000000000
--- a/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# py3.12 blocked by nodeenv
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
- ')"
-# coreutils requirement: see Bug #885559
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
- sys-apps/coreutils[-multicall]
-)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
-)
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-EPYTEST_DESELECT=(
- # All of these require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
- # and while some of them do include "skip if not found" logic, most of them do not.
- tests/languages/
- tests/repository_test.py
- # These three consistently fail with
- # Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
- # including with the sandbox disabled.
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_hook_stage_migration
- tests/main_test.py::test_try_repo
- # These two fail if pre-commit is already installed (Bug #894502)
- tests/commands/install_uninstall_test.py::test_environment_not_sourced
- tests/commands/install_uninstall_test.py::test_installed_from_venv
-)
-
-distutils_enable_tests pytest