summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-28 16:26:36 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-28 16:26:55 +0100
commitc0e7c659072809089e00cf1ce582cea58158dcb2 (patch)
tree98434157d61c0a737458f4ad4f13f94b0f0456a9 /eclass/ros-catkin.eclass
parentdev-ros/image_cb_detector: Fix build in C++11 mode. (diff)
downloadgentoo-c0e7c659072809089e00cf1ce582cea58158dcb2.tar.gz
gentoo-c0e7c659072809089e00cf1ce582cea58158dcb2.tar.bz2
gentoo-c0e7c659072809089e00cf1ce582cea58158dcb2.zip
eclass/ros-catkin.eclass: Build all ROS packages in C++11 mode.
Some of them require it, all dev-ros category should have been fixed to build in C++11 mode now. Suggested by Victor Mataré in bug #605466, fixing all its dupes too.
Diffstat (limited to 'eclass/ros-catkin.eclass')
-rw-r--r--eclass/ros-catkin.eclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/eclass/ros-catkin.eclass b/eclass/ros-catkin.eclass
index 28cf80dba3d2..61d01429b544 100644
--- a/eclass/ros-catkin.eclass
+++ b/eclass/ros-catkin.eclass
@@ -47,7 +47,7 @@ if [ -n "${PYTHON_COMPAT}" ] ; then
PYTHON_ECLASS="python-r1 python-utils-r1"
fi
-inherit ${SCM} ${PYTHON_ECLASS} cmake-utils
+inherit ${SCM} ${PYTHON_ECLASS} cmake-utils flag-o-matic
CATKIN_DO_PYTHON_MULTIBUILD=""
if [ -n "${PYTHON_COMPAT}" ] ; then
@@ -146,6 +146,10 @@ ros-catkin_src_prepare() {
if [ ! -f "${S}/CMakeLists.txt" ] ; then
catkin_init_workspace || die
fi
+
+ # Most packages require C++11 these days. Do it here, in src_prepare so that
+ # ebuilds can override it in src_configure.
+ append-cxxflags '-std=c++11'
}
# @FUNCTION: ros-catkin_src_configure_internal