summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/awale
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/awale')
-rw-r--r--games-board/awale/Manifest2
-rw-r--r--games-board/awale/awale-1.5.ebuild59
-rw-r--r--games-board/awale/files/awale-1.5-build.patch116
-rw-r--r--games-board/awale/metadata.xml6
4 files changed, 183 insertions, 0 deletions
diff --git a/games-board/awale/Manifest b/games-board/awale/Manifest
new file mode 100644
index 000000000000..95d4c5368e93
--- /dev/null
+++ b/games-board/awale/Manifest
@@ -0,0 +1,2 @@
+DIST awale-1.5-no-autoreconf2.patch.xz 37268 SHA256 239a8a1a0540353d701783f3163b921e38cf0965b461f695e3e3724869e1837e SHA512 857814c6ffe828bb0c3b82c214932ddf95162b7abaac6720db987f2af31a3b144543773a607edc70e0fceb8433f2aa519d3cfaca7474750cb45074aef0c37cb1 WHIRLPOOL f278edd456a702dc05f01bdec483fe634f0e09469595664aa5e22b8892ea4508dbd797c81dd9c9473ac46e2e028540a157bb91c66f72fe9dfffa0692295fe902
+DIST awale-1.5.tar.gz 489357 SHA256 8bf9812fd6cfe142e18a35474f6a366c1b12f960863a33421f6d2e448ed47014 SHA512 b3f33068d7d6cfd964051e15cfd84e7f2c8483c30f2ccea35e2dddb34353ea984561fdf28c0d668404d80cda89c6d5fcd0004a1a86d92325e5f6fc2f88197c61 WHIRLPOOL 05b46f8f8ea89236aa30755f4d6f39daa24135421220f35e4c96f919facb138871735ebe5f1741e29f4a2fc6572381ad2aa0768197112c22eaf961b0d9814792
diff --git a/games-board/awale/awale-1.5.ebuild b/games-board/awale/awale-1.5.ebuild
new file mode 100644
index 000000000000..a0347e497782
--- /dev/null
+++ b/games-board/awale/awale-1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# do not use autotools related stuff in stable ebuilds
+# unless you like random breakage: 469796, 469798, 424041
+
+EAPI=5
+
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="Free Awale - The game of all Africa"
+HOMEPAGE="http://www.nongnu.org/awale/"
+SRC_URI="mirror://nongnu/awale/${P}.tar.gz"
+SRC_URI="${SRC_URI} http://dev.gentoo.org/~hasufell/distfiles/${P}-no-autoreconf2.patch.xz" # STABLE ARCH
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="tk"
+
+RDEPEND="tk? ( dev-lang/tcl:0= dev-lang/tk:0= )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+
+ mv src/xawale.tcl src/xawale.tcl.in || die
+ mv configure.in configure.ac
+ rm aclocal.m4
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --mandir=/usr/share/man \
+ --with-iconsdir=/usr/share/icons/hicolor/48x48/apps \
+ --with-desktopdir=/usr/share/applications \
+ $(use_enable tk)
+}
+
+src_install() {
+ default
+ prepgamesdirs
+ use tk && fperms +x "${GAMES_DATADIR}"/${PN}/xawale.tcl
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ use tk && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ use tk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use tk && gnome2_icon_cache_update
+}
diff --git a/games-board/awale/files/awale-1.5-build.patch b/games-board/awale/files/awale-1.5-build.patch
new file mode 100644
index 000000000000..0e8ca136a410
--- /dev/null
+++ b/games-board/awale/files/awale-1.5-build.patch
@@ -0,0 +1,116 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat Jan 26 20:04:17 UTC 2013
+Subject: build system
+
+ fix FHS compliance
+ add several switches for icon, desktopdir and tk
+ fix a few macros
+
+--- awale-1.5/src/Makefile.am
++++ awale-1.5/src/Makefile.am
+@@ -1,24 +1,30 @@
+ bin_PROGRAMS = awale
+ awale_SOURCES = awale.c getopt.c getopt1.c getopt.h
+-INCLUDES = -I. -I$(srcdir)
++AM_CPPFLAGS = -I. -I$(srcdir)
++
++if TK_GUI
+ bin_SCRIPTS = xawale
+ xawale:
+ echo "#! /bin/sh" >$@
+- echo '`dirname $$0`/../share/awale/xawale.tcl' >>$@
++ echo "cd \"$(datadir)/awale/\" ; exec \"$(datadir)/awale/xawale.tcl\"" >>$@
+ chmod ugo+x $@
+-appdir = $(prefix)/share/applications
++appdir = @DESKTOPFILESDIR@
+ app_DATA = awale.desktop
+ awale.desktop:
+ echo "[Desktop Entry]" >$@
+ echo "Name=Free Awale" >>$@
+ echo "Comment=Awale game" >>$@
+ echo "Exec=xawale" >>$@
+- echo 'Icon=$(pkgdatadir)/awale.png' >>$@
++ echo 'Icon=awale' >>$@
+ echo "Terminal=false" >>$@
+ echo "Type=Application" >>$@
+ echo "Categories=Game;BoardGame;" >>$@
+ chmod 644 $@
+ CLEANFILES = xawale awale.desktop
++
++xawale.tcl:
++ sed 's|@my_bindir@|$(bindir)|' < $@.in > $@
++
+ pkgdata_SCRIPTS = xawale.tcl
+ dist_pkgdata_DATA = Trou00.gif Trou01.gif Trou02.gif Trou03.gif Trou04.gif Trou05.gif \
+ Trou06.gif Trou07.gif Trou08.gif Trou09.gif Trou10.gif Trou11.gif \
+@@ -28,3 +34,8 @@
+ Trou06.gif Trou07.gif Trou08.gif Trou09.gif Trou10.gif Trou11.gif \
+ Trou12.gif Trou13.gif Trou14.gif Trou15.gif board.gif copyright.gif \
+ awale.png awale.ico uk.gif fr.gif sp.gif AwaleBanner.bmp README
++
++# icon
++iconsdir = @ICONSDIR@
++dist_icons_DATA = awale.png
++endif
+--- awale-1.5/configure.in
++++ awale-1.5/configure.in
+@@ -1,6 +1,34 @@
+-AC_INIT(awale.c)
+-AM_INIT_AUTOMAKE(awale, 1.5)
++AC_INIT([awale], [1.5])
++AM_INIT_AUTOMAKE([-Wall])
+ AC_CONFIG_SRCDIR([src/awale.c])
+ AC_PROG_CC
++
++
++# let user specify desktopdir
++AC_ARG_WITH([desktopdir],
++ [AS_HELP_STRING([--with-desktopdir=DIR],
++ [path where desktop files get installed (default: $datadir/applications)])],
++ [DESKTOPFILESDIR="$withval"],
++ [DESKTOPFILESDIR='$(datadir)/applications'])
++
++# let user specify iconsdir
++AC_ARG_WITH([iconsdir],
++ [AS_HELP_STRING([--with-iconsdir=DIR],
++ [path where icons get installed (default: $datadir/pixmaps)])],
++ [ICONSDIR="$withval"],
++ [ICONSDIR='$(datadir)/pixmaps'])
++
++# configure-switch for tkgui
++AC_ARG_ENABLE([tk],
++ [AS_HELP_STRING([--enable-tk],
++ [enable tk gui (default: enable)])],
++ [enable_tk=$enableval],
++ [enable_tk="no"])
++
++AM_CONDITIONAL([TK_GUI], [test "x$enable_tk" = "xyes"])
++
++AC_SUBST([ICONSDIR])
++AC_SUBST([DESKTOPFILESDIR])
++
+ AC_CONFIG_FILES([Makefile src/Makefile man/Makefile])
+ AC_OUTPUT
+
+--- awale-1.5/man/Makefile.am
++++ awale-1.5/man/Makefile.am
+@@ -1,3 +1,7 @@
+-mandir = $(prefix)/share/man
++if TK_GUI
+ man_MANS = awale.6 xawale.6
++else
++man_MANS = awale.6
++endif
++
+ EXTRA_DIST = $(man_MANS)
+--- awale-1.5/src/xawale.tcl
++++ awale-1.5/src/xawale.tcl
+@@ -693,7 +693,7 @@
+
+ switch $tcl_platform(platform) {
+ "unix" {
+- set JOUER [file join [file dirname [info script]] .. .. bin awale]
++ set JOUER "@my_bindir@/awale"
+ }
+ "macintosh" {
+ set JOUER [file join [file dirname [info script]] .. .. bin awale]
diff --git a/games-board/awale/metadata.xml b/games-board/awale/metadata.xml
new file mode 100644
index 000000000000..01a746edb196
--- /dev/null
+++ b/games-board/awale/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
+