summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /games-fps
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/legends/legends-0.4.1.43-r2.ebuild4
-rw-r--r--games-fps/serious-sam-tse/serious-sam-tse-1_beta1-r1.ebuild5
-rw-r--r--games-fps/ut2003-data/ut2003-data-2107.ebuild8
-rw-r--r--games-fps/wolfgl/wolfgl-0.93-r2.ebuild2
4 files changed, 9 insertions, 10 deletions
diff --git a/games-fps/legends/legends-0.4.1.43-r2.ebuild b/games-fps/legends/legends-0.4.1.43-r2.ebuild
index 0412178e3f4b..e516f30fffca 100644
--- a/games-fps/legends/legends-0.4.1.43-r2.ebuild
+++ b/games-fps/legends/legends-0.4.1.43-r2.ebuild
@@ -46,11 +46,11 @@ src_unpack() {
src_install() {
insinto "${dir}"
- doins -r * || die "doins * failed"
+ doins -r *
rm "${D}/${dir}/"/{lindedicated,LinLegends,*.so.0}
exeinto "${dir}"
- doexe lindedicated LinLegends *.so.0 || die "doexe failed"
+ doexe lindedicated LinLegends *.so.0
make_wrapper ${PN} "./LinLegends" "${dir}" "${dir}"
if use dedicated ; then
diff --git a/games-fps/serious-sam-tse/serious-sam-tse-1_beta1-r1.ebuild b/games-fps/serious-sam-tse/serious-sam-tse-1_beta1-r1.ebuild
index 266685806eba..0a0dc429f256 100644
--- a/games-fps/serious-sam-tse/serious-sam-tse-1_beta1-r1.ebuild
+++ b/games-fps/serious-sam-tse/serious-sam-tse-1_beta1-r1.ebuild
@@ -77,7 +77,7 @@ src_install() {
einfo "Copying from ${CDROM_ROOT}"
insinto "${dir}"
- doins -r "${CDROM_ROOT}"/Install/* || die "doins CD failed"
+ doins -r "${CDROM_ROOT}"/Install/*
# Correct paths of copied resource files
mv "${D}/${dir}"/Locales/eng/Controls/* "${D}/${dir}"/Controls/ || die "Failed to move file"
@@ -105,8 +105,7 @@ src_install() {
mv Levels/Mods/Warped/ Mods/ || die "Failed to move file"
rmdir Levels/Mods/ || die "Failed to remove dir"
- doins -r Bin Data Levels Mods *.txt README* \
- || die "doins main failed"
+ doins -r Bin Data Levels Mods *.txt README*
# Install bins last to ensure they are marked executable
exeinto "${dir}"
diff --git a/games-fps/ut2003-data/ut2003-data-2107.ebuild b/games-fps/ut2003-data/ut2003-data-2107.ebuild
index 933dc8498d89..4a77c1f15e5a 100644
--- a/games-fps/ut2003-data/ut2003-data-2107.ebuild
+++ b/games-fps/ut2003-data/ut2003-data-2107.ebuild
@@ -93,7 +93,7 @@ src_install() {
# copy libraries
exeinto "${dir}"/System
- doexe "${S}"/System/libSDL-1.2.so.0 || die
+ doexe "${S}"/System/libSDL-1.2.so.0
# uncompressing files
einfo "Uncompressing files... this may take a while..."
@@ -102,12 +102,12 @@ src_install() {
done
# installing documentation/icon
- dodoc "${S}"/README.linux || die "dodoc README.linux"
+ dodoc "${S}"/README.linux
newicon "${S}"/Unreal.xpm ut2003.xpm || die "copying icon"
- doins "${S}"/README.linux "${S}"/Unreal.xpm || die "copying readme/icon"
+ doins "${S}"/README.linux "${S}"/Unreal.xpm
# copy ut2003/ucc
exeinto "${dir}"
- doexe "${S}"/bin/ut2003 "${S}"/ucc || die "copying ut2003/ucc"
+ doexe "${S}"/bin/ut2003 "${S}"/ucc
# Here we apply DrSiN's crash patch
cp "${S}"/CrashFix/System/crashfix.u "${Ddir}"/System
diff --git a/games-fps/wolfgl/wolfgl-0.93-r2.ebuild b/games-fps/wolfgl/wolfgl-0.93-r2.ebuild
index a76843aa4066..8bb95ed031e2 100644
--- a/games-fps/wolfgl/wolfgl-0.93-r2.ebuild
+++ b/games-fps/wolfgl/wolfgl-0.93-r2.ebuild
@@ -35,7 +35,7 @@ PATCHES=(
)
src_compile() {
- emake -j1 CFLAGS="${CFLAGS}" DATADIR="/usr/share/${PN}" || die "emake failed"
+ emake -j1 CFLAGS="${CFLAGS}" DATADIR="/usr/share/${PN}"
}
src_install() {