summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-libs/pantomime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-libs/pantomime')
-rw-r--r--gnustep-libs/pantomime/Manifest2
-rw-r--r--gnustep-libs/pantomime/metadata.xml11
-rw-r--r--gnustep-libs/pantomime/pantomime-1.2.0.ebuild36
-rw-r--r--gnustep-libs/pantomime/pantomime-1.2.2.ebuild36
4 files changed, 85 insertions, 0 deletions
diff --git a/gnustep-libs/pantomime/Manifest b/gnustep-libs/pantomime/Manifest
new file mode 100644
index 000000000000..a8ef697864d0
--- /dev/null
+++ b/gnustep-libs/pantomime/Manifest
@@ -0,0 +1,2 @@
+DIST Pantomime-1.2.0.tar.gz 466206 SHA256 c6484634dd0611d07108e7e006a2c6bdbe3e72b23de7473440df9a559f6b6218
+DIST Pantomime-1.2.2.tar.gz 468276 SHA256 f87b6b362b56c2b22667e614432f222604e318e61340a13b30c8277b180a3be8 SHA512 198c1e0248f47bbd2cc284eec0d804959ea2a51e4a4810f8909048b41fc4bfbbaab9fc86e1ad507611a77382f353b357615c52845228e2411a0da7af88b2988f WHIRLPOOL 93895bcf5819e1d5e8cbc23b21e70e51574f320d25a234ae7cd51873d7da0e1df4b4d4bffcbdf1b8faa172044b8a63212f47ca0340b53247fd9250d4cb293b18
diff --git a/gnustep-libs/pantomime/metadata.xml b/gnustep-libs/pantomime/metadata.xml
new file mode 100644
index 000000000000..188fd7b76cba
--- /dev/null
+++ b/gnustep-libs/pantomime/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<herd>proxy-maintainers</herd>
+<longdescription>
+A set of Objective-C classes that model a mail system.
+Author Ludovic Marcotte ludovic@Sophos.ca
+The name "Pantomime" was proposed by Jay Kominek.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-libs/pantomime/pantomime-1.2.0.ebuild b/gnustep-libs/pantomime/pantomime-1.2.0.ebuild
new file mode 100644
index 000000000000..7015ff5e5fd7
--- /dev/null
+++ b/gnustep-libs/pantomime/pantomime-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils gnustep-2
+
+MY_P=${P/p/P}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A set of Objective-C classes that model a mail system"
+HOMEPAGE="http://www.collaboration-world.com/pantomime/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 Elm"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s|ADDITIONAL_LDFLAGS|LIBRARIES_DEPEND_UPON|" \
+ Framework/Pantomime/GNUmakefile || die "as-needed sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd "${S}"/Documentation
+ dodoc AUTHORS README TODO
+ docinto rfc
+ dodoc RFC/*
+}
diff --git a/gnustep-libs/pantomime/pantomime-1.2.2.ebuild b/gnustep-libs/pantomime/pantomime-1.2.2.ebuild
new file mode 100644
index 000000000000..3c0efecfe8cd
--- /dev/null
+++ b/gnustep-libs/pantomime/pantomime-1.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnustep-2
+
+MY_P=${P/p/P}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A set of Objective-C classes that model a mail system"
+HOMEPAGE="http://www.collaboration-world.com/pantomime/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 Elm"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s|ADDITIONAL_LDFLAGS|LIBRARIES_DEPEND_UPON|" \
+ Framework/Pantomime/GNUmakefile || die "as-needed sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd "${S}"/Documentation
+ dodoc AUTHORS README TODO
+ docinto rfc
+ dodoc RFC/*
+}