summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/geeqie/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/geeqie/files')
-rw-r--r--media-gfx/geeqie/files/geeqie-1.2-fix-lcms2-integration.patch35
-rw-r--r--media-gfx/geeqie/files/geeqie-1.2-fix_version.patch11
2 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/geeqie/files/geeqie-1.2-fix-lcms2-integration.patch b/media-gfx/geeqie/files/geeqie-1.2-fix-lcms2-integration.patch
new file mode 100644
index 000000000000..5f13c92cb6db
--- /dev/null
+++ b/media-gfx/geeqie/files/geeqie-1.2-fix-lcms2-integration.patch
@@ -0,0 +1,35 @@
+From a1afabd3ce740872a857234b91eeb64fcf239f6a Mon Sep 17 00:00:00 2001
+From: Klaus Ethgen <Klaus@Ethgen.de>
+Date: Sat, 27 Sep 2014 12:07:10 +0100
+Subject: [PATCH] Fix lcms2 integration
+
+Thanks Michael Schwendt <mschwendt@gmail.com> for the bug reporting and
+the patch.
+---
+ src/color-man.c | 10 ++++++----
+ 1 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/src/color-man.c b/src/color-man.c
+index 7788c7a..e4f1bab 100644
+--- a/src/color-man.c
++++ b/src/color-man.c
+@@ -432,10 +432,12 @@ static gchar *color_man_get_profile_name(ColorManProfileType type, cmsHPROFILE p
+ if (profile)
+ {
+ #ifdef HAVE_LCMS2
+- cmsUInt8Number profileID[17];
+- profileID[16] = '\0';
+- cmsGetHeaderProfileID(profile, profileID);
+- return g_strdup((gchar *) profileID);
++ cmsUInt32Number r;
++ char buffer[20];
++ buffer[0] = '\0';
++ r = cmsGetProfileInfoASCII(profile, cmsInfoDescription, "en", "US", &buffer, 20);
++ buffer[19] = '\0'; /* Just to be sure */
++ return g_strdup(buffer);
+ #else
+ return g_strdup(cmsTakeProductName(profile));
+ #endif
+--
+1.7.1
+
diff --git a/media-gfx/geeqie/files/geeqie-1.2-fix_version.patch b/media-gfx/geeqie/files/geeqie-1.2-fix_version.patch
new file mode 100644
index 000000000000..1d40ea02b2d4
--- /dev/null
+++ b/media-gfx/geeqie/files/geeqie-1.2-fix_version.patch
@@ -0,0 +1,11 @@
+--- configure.in.orig 2014-10-26 20:33:53.431516625 +0100
++++ configure.in 2014-10-26 20:33:58.790520392 +0100
+@@ -15,7 +15,7 @@
+ dnl GNU General Public License for more details.
+
+ AC_PREREQ(2.57)
+-AC_INIT(geeqie, 1.1, geeqie-devel@lists.sourceforge.net)
++AC_INIT(geeqie, 1.2, geeqie-devel@lists.sourceforge.net)
+
+ # Check for rightly dirs
+ AC_CONFIG_SRCDIR([src/main.c])