summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/up-imapproxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/up-imapproxy')
-rw-r--r--net-mail/up-imapproxy/Manifest1
-rw-r--r--net-mail/up-imapproxy/files/imapproxy.initd21
-rw-r--r--net-mail/up-imapproxy/files/imapproxyd.864
-rw-r--r--net-mail/up-imapproxy/files/pimpstat.827
-rw-r--r--net-mail/up-imapproxy/files/up-imapproxy-1.2.7-ldflags.patch19
-rw-r--r--net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch20
-rw-r--r--net-mail/up-imapproxy/metadata.xml8
-rw-r--r--net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild66
8 files changed, 226 insertions, 0 deletions
diff --git a/net-mail/up-imapproxy/Manifest b/net-mail/up-imapproxy/Manifest
new file mode 100644
index 000000000000..9399dd396304
--- /dev/null
+++ b/net-mail/up-imapproxy/Manifest
@@ -0,0 +1 @@
+DIST squirrelmail-imap_proxy-1.2.7.tar.bz2 111651 SHA256 dd8ad40e3e457bd76fc9f19ef1c0d89911e3e3cc722415d1183f765dcac1ae48 SHA512 4b341fe5ea13241983c780ad2487ad5bd97136652b095f54ccf8f61d0f0818236d0d6e1005d46811cf3bd15896160fb172a40ae805ccc3ce7d6fc984099d2b2e WHIRLPOOL b0627781294cff742b189d802aa7e69ef6e60ffacefb800476f8dd28bbe973dc59c6e0b87d3fa1429ce06cf02b23c9fc9b6943ef9eaa7cb6f7f0ae8010a4a3e6
diff --git a/net-mail/up-imapproxy/files/imapproxy.initd b/net-mail/up-imapproxy/files/imapproxy.initd
new file mode 100644
index 000000000000..5ffda2d230f4
--- /dev/null
+++ b/net-mail/up-imapproxy/files/imapproxy.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use logger
+ need net
+}
+
+start() {
+ ebegin "Starting up-imapproxy"
+ start-stop-daemon --start --quiet --exec /usr/sbin/imapproxyd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping up-imapproxy"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/imapproxyd
+ eend $?
+}
diff --git a/net-mail/up-imapproxy/files/imapproxyd.8 b/net-mail/up-imapproxy/files/imapproxyd.8
new file mode 100644
index 000000000000..1c70d9525756
--- /dev/null
+++ b/net-mail/up-imapproxy/files/imapproxyd.8
@@ -0,0 +1,64 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH IMAPPROXYD 8 "Mar 12, 2004" "Dave McMurtrie" "IMAP proxy daemon"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.SH NAME
+.B imapproxyd
+\- IMAP proxy daemon
+.SH SYNOPSIS
+.B imapproxyd
+.RI
+[
+.B -f
+.RI
+<config file name> ]
+.RI
+[
+.B -p
+.RI
+<pidfile name> ]
+.br
+.SH DESCRIPTION
+This manual page documents briefly the
+.B imapproxyd
+command.
+This manual page was written for the Debian distribution
+because the original program does not have a manual page.
+.PP
+UP-ImapProxy proxies IMAP transactions between an IMAP client and an IMAP
+server. The general idea is that the client should never know that it is
+not talking to the real IMAP server, but ImapProxy caches server connections.
+.PP
+ImapProxy was written to compensate for webmail clients that are unable to
+maintain persistent connections to an IMAP server. Most webmail clients
+need to log in to an IMAP server for nearly every single transaction; This
+behaviour can cause tragic performance problems on the IMAP server.
+ImapProxy tries to deal with this problem by leaving server connections
+open for a short time after a webmail client logs out. When the webmail
+client connects again, ImapProxy will determine if there is a cached
+connection available and reuse it if possible.
+.BR
+.SH FILES
+By default, UP-ImapProxy reads /etc/imapproxy.conf on startup.
+This can be changed by using the
+.I -f
+option
+.PP
+Unless foreground_mode has been enabled, UP-ImapProxy will write its PID to to
+a PID-file. It defaults to /var/run/imapproxy.pid, but can be overridden with
+the
+.I -p
+option
+.SH SEE ALSO
+.BR pimpstat (8),
+.br
+.SH AUTHOR
+This manual page was written by Jose Luis Tallon
+.nh
+<jltallon@adv-solutions.net>,
+for the Debian GNU/Linux system (but may be used by others).
+
+
diff --git a/net-mail/up-imapproxy/files/pimpstat.8 b/net-mail/up-imapproxy/files/pimpstat.8
new file mode 100644
index 000000000000..2466e7ce2780
--- /dev/null
+++ b/net-mail/up-imapproxy/files/pimpstat.8
@@ -0,0 +1,27 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH PIMPSTATS 8 "Mar 12, 2004" "Dave McMurtrie" "IMAP proxy daemon"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.SH NAME
+ pimpstat \- UP-ImapProxy statistics
+.SH SYNOPSIS
+.B pimpstat
+.RI [options]
+.br
+.SH DESCRIPTION
+This manual page documents briefly the
+.B pimpstat
+command.
+This manual page was written for the Debian distribution
+because the original program does not have a manual page.
+.SH SEE ALSO
+.BR imapproxyd (8),
+.br
+.SH AUTHOR
+This manual page was written by Jose Luis Tallon
+.nh
+<jltallon@adv-solutions.net>,
+for the Debian GNU/Linux system (but may be used by others).
diff --git a/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-ldflags.patch b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-ldflags.patch
new file mode 100644
index 000000000000..4ba1b6b725e5
--- /dev/null
+++ b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-ldflags.patch
@@ -0,0 +1,19 @@
+commit 98876519b581c0427b81d772f56b25ad3d0121df
+Author: Eray Aslan <eras@gentoo.org>
+Date: Sun Jun 5 19:43:41 2011 +0300
+
+ respect LDFLAGS
+
+diff --git a/Makefile.in b/Makefile.in
+index 1b235b8..8ac1e4f 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -70,7 +70,7 @@ $(XYD_BIN): $(XYD_OBJ)
+ $(CC) -o $@ $(XYD_OBJ) $(LDFLAGS) $(XYD_LIB)
+
+ $(TAT_BIN): $(TAT_OBJ)
+- $(CC) -o $@ $(TAT_OBJ) $(TAT_LIB)
++ $(CC) -o $@ $(TAT_OBJ) $(LDFLAGS) $(TAT_LIB)
+
+ clean:
+ rm -f ./src/core $(XYD_OBJ) $(TAT_OBJ) $(XYD_BIN) $(TAT_BIN)
diff --git a/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch
new file mode 100644
index 000000000000..cbe19e8c0eb7
--- /dev/null
+++ b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch
@@ -0,0 +1,20 @@
+--- a/configure.in
++++ b/configure.in
+@@ -121,12 +121,16 @@
+ save_LIBS="$LIBS"
+ LIB_CURSES=""
+ AC_CHECK_LIB(curses, initscr, LIB_CURSES="-lcurses", [ curses_found=no ])
+-if test "$curses_found" == no; then
++if test "$curses_found" = no; then
+ AC_CHECK_LIB(ncurses, initscr, LIB_CURSES="-lncurses",
+ AC_ERROR([Can't compile without curses!!!]))
+ fi
+
+ LIBS="$save_LIBS"
++
++AC_SEARCH_LIBS(stdscr, tinfo curses ncurses, [LIB_CURSES="$LIB_CURSES $ac_cv_search_stdscr"],
++ AC_MSG_ERROR([Cannot find a library providing stdscr]))
++
+ AC_SUBST(LIB_CURSES)
+
+
diff --git a/net-mail/up-imapproxy/metadata.xml b/net-mail/up-imapproxy/metadata.xml
new file mode 100644
index 000000000000..f228f9b4cc58
--- /dev/null
+++ b/net-mail/up-imapproxy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">squirrelmail</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild b/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild
new file mode 100644
index 000000000000..a6aef1ecd1c5
--- /dev/null
+++ b/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_AUTOCONF="2.1"
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Proxy IMAP transactions between an IMAP client and an IMAP server"
+HOMEPAGE="http://www.imapproxy.org/"
+SRC_URI="mirror://sourceforge/squirrelmail/squirrelmail-imap_proxy-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="kerberos ssl +tcpd"
+
+RDEPEND="sys-libs/ncurses
+ kerberos? ( virtual/krb5 )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+S=${WORKDIR}/squirrelmail-imap_proxy-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-ldflags.patch
+ epatch "${FILESDIR}/${P}"-tinfo.patch
+
+ sed -i \
+ -e 's:in\.imapproxyd:imapproxyd:g' \
+ README Makefile.in include/imapproxy.h || die
+
+ #buffer oveflow
+ #http://lists.andrew.cmu.edu/pipermail/imapproxy-info/2010-June/000874.html
+ sed -i \
+ -e "/define BUFSIZE/s/4096/8192/" \
+ -e "/define MAXPASSWDLEN/s/64/8192/" \
+ include/imapproxy.h
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_with kerberos krb5) \
+ $(use_with ssl openssl) \
+ $(use_with tcpd libwrap)
+}
+
+src_install() {
+ dosbin bin/imapproxyd bin/pimpstat
+
+ insinto /etc
+ doins scripts/imapproxy.conf
+
+ newinitd "${FILESDIR}"/imapproxy.initd imapproxy
+
+ dodoc ChangeLog README README.known_issues
+ use ssl && dodoc README.ssl
+
+ doman "${FILESDIR}"/*.8
+}