summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-11-07 22:08:04 -0500
committerMike Gilbert <floppym@gentoo.org>2021-11-07 22:21:58 -0500
commitecdbe4d5889f29da10e7ae49a8d9fc330700de6d (patch)
tree55914b677de1f7742391f16f449197eb12831d32 /sci-geosciences/gpsd
parentx11-libs/snorenotify: keyword ~riscv (diff)
downloadgentoo-ecdbe4d5889f29da10e7ae49a8d9fc330700de6d.tar.gz
gentoo-ecdbe4d5889f29da10e7ae49a8d9fc330700de6d.tar.bz2
gentoo-ecdbe4d5889f29da10e7ae49a8d9fc330700de6d.zip
sci-geosciences/gpsd: fix systemd unit path
Closes: https://bugs.gentoo.org/822327 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/gpsd-3.23.1-r1.ebuild (renamed from sci-geosciences/gpsd/gpsd-3.23.1.ebuild)4
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sci-geosciences/gpsd/gpsd-3.23.1.ebuild b/sci-geosciences/gpsd/gpsd-3.23.1-r1.ebuild
index 04c23389ed2b..d602376843ef 100644
--- a/sci-geosciences/gpsd/gpsd-3.23.1.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.23.1-r1.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{8,9,10} )
SCONS_MIN_VERSION="2.3.0"
-inherit udev distutils-r1 scons-utils toolchain-funcs
+inherit udev distutils-r1 scons-utils systemd toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
@@ -146,7 +146,7 @@ src_configure() {
gpsd_group=dialout
nostrip=True
systemd=$(usex systemd)
- unitdir="\$prefix/$(get_libdir)"
+ unitdir="$(systemd_get_systemunitdir)"
shared=$(usex !static True False)
bluez=$(usex bluetooth)
libgpsmm=$(usex cxx)
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 456c84a9790f..4e8c7af4c741 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{8,9,10} )
SCONS_MIN_VERSION="2.3.0"
-inherit udev distutils-r1 scons-utils toolchain-funcs
+inherit udev distutils-r1 scons-utils systemd toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
@@ -146,7 +146,7 @@ src_configure() {
gpsd_group=dialout
nostrip=True
systemd=$(usex systemd)
- unitdir="\$prefix/$(get_libdir)"
+ unitdir="$(systemd_get_systemunitdir)"
shared=$(usex !static True False)
bluez=$(usex bluetooth)
libgpsmm=$(usex cxx)