summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-03-16 21:41:52 -0400
committerMike Gilbert <floppym@gentoo.org>2019-03-16 21:41:52 -0400
commit3540e0cd37ff19e64cf74bef70d6e84607e052c8 (patch)
treec16d81cd99da70238d06ea2ffcaa36e12dd8c99b /sys-apps/hwids
parentdev-python/qrcode: keyword ~arm (diff)
downloadgentoo-3540e0cd37ff19e64cf74bef70d6e84607e052c8.tar.gz
gentoo-3540e0cd37ff19e64cf74bef70d6e84607e052c8.tar.bz2
gentoo-3540e0cd37ff19e64cf74bef70d6e84607e052c8.zip
sys-apps/hwids: bump to 20190316
Package-Manager: Portage-2.3.62, Repoman-2.3.12_p83 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/hwids')
-rw-r--r--sys-apps/hwids/Manifest1
-rw-r--r--sys-apps/hwids/hwids-20190316.ebuild92
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild4
3 files changed, 95 insertions, 2 deletions
diff --git a/sys-apps/hwids/Manifest b/sys-apps/hwids/Manifest
index 5ea81af64bdf..2c3103b4e062 100644
--- a/sys-apps/hwids/Manifest
+++ b/sys-apps/hwids/Manifest
@@ -4,3 +4,4 @@ DIST hwids-20171003.tar.gz 3035908 BLAKE2B 8ecce99f6a6233b3dd79e1663053b6718fd8b
DIST hwids-20180315.tar.gz 3117949 BLAKE2B 34b6349d7adf38da8591a0f75e98ce09f0217bb284d1bdc70d7c1bd0a13f0c21b46b2a40ea363dfcdb7524e2a06e94d8ca3a63f5dce6f4afac2b20d05229e944 SHA512 2c52b88b74d231f7c563079b02fdbe29ff70c4df5aae64f1241ab0e1bd3ab9c3ca925e102474e32d3dc8dcb833e3451f0698024a8fff808a987ce468af281898
DIST hwids-20180518.tar.gz 3150553 BLAKE2B e7d1be88349d04dac09e44bba728d1b371be66628d0143a5ab9d98f9ac5ce14bc21c272bdc93e88cb2af8f640f2f5d0497be8a33a136bcb8e69112a998be3827 SHA512 5a8e65b226026b59008c714df79309a888f728198ac5ab71c5908b69a1fd5365a0834afab0e38423affbda59ded04b662a09dc544b4d96695671f562aa0c5ec1
DIST hwids-20180917.tar.gz 3211960 BLAKE2B d1dc00994a63a6cb6f7c41c73267dcc38b59a46b9e627fac9d6df285b8d1abf5d1335c02c047bff2b09c9ed9f8e4a1c79329c1bd7dd932949d3db2bbb5b9b2e6 SHA512 9fdcd5a7b3adca1bed886aa83e9cf3944391a819fc9f09b673bd815d95e6e70cecf40d8e87287207e34bfeb58c888188fc61b1c0ac13c1ecab0efbdb5100f8d9
+DIST hwids-20190316.tar.gz 3312959 BLAKE2B d9f4c7170979c404a69ca0b51903af34db01a6150ec70dc1416dcb507dfa4d8ad9ce325204791a24e5646dee67aea0c1566c15dcddb65a5d9dddbbbb9b896398 SHA512 6db50577b5d29d73f1dc0a44d0b74320cb0df186b9850160b15a6e8f2bcbdbf8193bae4146f81a5afc6b0e05706b5286b4b5858eb028d6c58ea4582df61d232e
diff --git a/sys-apps/hwids/hwids-20190316.ebuild b/sys-apps/hwids/hwids-20190316.ebuild
new file mode 100644
index 000000000000..5b05dcf19fcb
--- /dev/null
+++ b/sys-apps/hwids/hwids-20190316.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit udev
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+if [[ ${PV} == "99999999" ]]; then
+ PYTHON_COMPAT=( python3_{6,7} )
+ inherit git-r3 python-any-r1
+ EGIT_REPO_URI="${HOMEPAGE}.git"
+else
+ SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+IUSE="+net +pci +udev +usb"
+
+DEPEND=""
+RDEPEND="
+ udev? ( virtual/udev )
+ !<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1
+"
+
+if [[ ${PV} == 99999999 ]]; then
+ DEPEND+="
+ net-misc/curl
+ udev? ( $(python_gen_any_dep 'dev-python/pyparsing[${PYTHON_USEDEP}]') )
+ "
+ python_check_deps() {
+ if use udev; then
+ has_version --host-root "dev-python/pyparsing[${PYTHON_USEDEP}]"
+ fi
+ }
+else
+ S=${WORKDIR}/hwids-${P}
+fi
+
+pkg_setup() {
+ :
+}
+
+src_unpack() {
+ if [[ ${PV} == 99999999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ emake fetch
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e '/udevadm hwdb/d' Makefile || die
+}
+
+_emake() {
+ emake \
+ NET=$(usex net) \
+ PCI=$(usex pci) \
+ UDEV=$(usex udev) \
+ USB=$(usex usb) \
+ "$@"
+}
+
+src_compile() {
+ if [[ ${PV} == 99999999 ]] && use udev; then
+ python_setup
+ _emake udev-hwdb
+ fi
+ _emake
+}
+
+src_install() {
+ _emake install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}
+
+pkg_postinst() {
+ if use udev; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ fi
+}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 79a041389fd9..5b05dcf19fcb 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -8,7 +8,7 @@ inherit udev
DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
HOMEPAGE="https://github.com/gentoo/hwids"
if [[ ${PV} == "99999999" ]]; then
- PYTHON_COMPAT=( python3_6 )
+ PYTHON_COMPAT=( python3_{6,7} )
inherit git-r3 python-any-r1
EGIT_REPO_URI="${HOMEPAGE}.git"
else