summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-19 16:23:55 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-19 16:26:34 -0700
commit8c08b604bcc45c0a83a0ddeb54d60629c999ebcb (patch)
tree47d149a8e2b8edca8c48767a87dc688666ce6458 /sys-libs/librtas
parentnet-libs/nghttp2: bump to version 1.49.0 (diff)
downloadgentoo-8c08b604bcc45c0a83a0ddeb54d60629c999ebcb.tar.gz
gentoo-8c08b604bcc45c0a83a0ddeb54d60629c999ebcb.tar.bz2
gentoo-8c08b604bcc45c0a83a0ddeb54d60629c999ebcb.zip
sys-libs/librtas: add 2.0.3
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-libs/librtas')
-rw-r--r--sys-libs/librtas/Manifest1
-rw-r--r--sys-libs/librtas/librtas-2.0.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/librtas/Manifest b/sys-libs/librtas/Manifest
index 696537d43241..d47a6a52926a 100644
--- a/sys-libs/librtas/Manifest
+++ b/sys-libs/librtas/Manifest
@@ -1 +1,2 @@
DIST librtas-2.0.2.tar.gz 91627 BLAKE2B 1455af1af4a932fb81815ba67d1d1d8eeb0866bcf49fdcced622c1982121b5bb3ddeaf78f121a6540ec6c60d641991a87342713478a5be5232128db35d272059 SHA512 112d355bc486657289a186d9f1b8c576af55422f1527259a0cd680c07d6fa787aef2dc0cb6322721dc4aa1c5bd1de669f5c4d05e6a07de65262e9e3d4d0283c7
+DIST librtas-2.0.3.tar.gz 95483 BLAKE2B 38ce5c3924dfdb18f3a9a6e309a0ba093468b12e05b38dd81525b59ddd5afda65da3c46b7b48c1e8aaa1dc0afc6cb1eaf7d930e6e27bb1a06005a7f24620a9cd SHA512 3ff59007ad6fc893d226ae9413b57b8b478a214a824f60c2af58a65c0a3cefecc0d19bb4c791b677a0d5c1d7da9646d66f48d0e0446768092ef7afd6e4baff34
diff --git a/sys-libs/librtas/librtas-2.0.3.ebuild b/sys-libs/librtas/librtas-2.0.3.ebuild
new file mode 100644
index 000000000000..5c3f2b58d7b1
--- /dev/null
+++ b/sys-libs/librtas/librtas-2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A set of libraries for userspace access to RTAS on the PowerPC platform(s)"
+HOMEPAGE="https://github.com/ibm-power-utilities/librtas"
+SRC_URI="https://github.com/ibm-power-utilities/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~ppc64-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install docdir="${EPREFIX}"/usr/share/doc/${PF}
+ find "${D}" -name '*.la' -delete || die
+ # librtas_src/syscall_rmo.c: static const char *lockfile_path = "/var/lock/LCK..librtas";
+ # this way we prevent sandbox violations in lscpu linked to rtas
+ dodir /etc/sandbox.d
+ echo 'SANDBOX_PREDICT="/run/lock/LCK..librtas"' > "${ED}"/etc/sandbox.d/50librtas || die
+}