summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/procexp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/procexp')
-rw-r--r--sys-process/procexp/Manifest1
-rw-r--r--sys-process/procexp/metadata.xml12
-rw-r--r--sys-process/procexp/procexp-1.5.277.ebuild72
3 files changed, 85 insertions, 0 deletions
diff --git a/sys-process/procexp/Manifest b/sys-process/procexp/Manifest
new file mode 100644
index 000000000000..3d8bec371e1f
--- /dev/null
+++ b/sys-process/procexp/Manifest
@@ -0,0 +1 @@
+DIST process_explorer-1.5-277.noarch.rpm 146630 SHA256 b58dd139c16295d1d89937ddd684b7298f9d5b175b6dc5ce580ec073f7cf3792 SHA512 bdf03a0cbce621791ed272d61ee230a672caa8cd2d16e52b4fc256fe7955dc93636108dffdae30375e0b497d9378a8c3fdf6fc8bbd66cf04254596507d17dbef WHIRLPOOL f7098d8744666a49abb148e683b18c990385f8dba6f9aeb94832fb3531227d635b5f8f85316237a12ddc0e2182550993275d6c882a5e70d19119c63f6b83ed42
diff --git a/sys-process/procexp/metadata.xml b/sys-process/procexp/metadata.xml
new file mode 100644
index 000000000000..c900ff1e9017
--- /dev/null
+++ b/sys-process/procexp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">procexp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-process/procexp/procexp-1.5.277.ebuild b/sys-process/procexp/procexp-1.5.277.ebuild
new file mode 100644
index 000000000000..c32615bf2b23
--- /dev/null
+++ b/sys-process/procexp/procexp-1.5.277.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils gnome2-utils multilib python-single-r1 rpm versionator
+
+MY_P="process_explorer-$(replace_version_separator 2 '-')"
+
+DESCRIPTION="Graphical process explorer"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/procexp/index.php?title=Main_Page"
+SRC_URI="mirror://sourceforge/project/procexp/${MY_P}.noarch.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pyqwt[${PYTHON_USEDEP}]
+ sys-auth/polkit"
+
+S="${WORKDIR}/opt/${MY_P}/${PN}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# No build system provided by upstream
+# https://sourceforge.net/tracker/?func=detail&aid=3573774&group_id=309156&atid=1301952
+
+src_prepare() {
+ # Removing unnecessary svn cruft
+ esvn_clean
+
+ rm make_rpm.py process_explorer.spec ${PN}.desktop ${PN}.sh || die 'remove unneeded files failed'
+
+ epatch_user
+
+ python_fix_shebang .
+}
+
+src_install() {
+ newicon -s 48 icon.png ${PN}.png
+ rm icon.png || die
+
+ insinto "/usr/share/polkit-1/actions"
+ doins com.procexp.pkexec.policy
+ rm com.procexp.pkexec.policy || die
+
+ insinto "/usr/$(get_libdir)/${PN}"
+ doins -r *
+ fperms +x "/usr/$(get_libdir)/${PN}/procexp.py"
+ fperms +x "/usr/$(get_libdir)/${PN}/rootproxy/procroot.py"
+
+ dosym "/usr/$(get_libdir)/${PN}/procexp.py" /usr/bin/procexp
+ make_desktop_entry ${PN} "Linux Process Explorer" ${PN} "System;Utility;"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}