summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-02-20 18:24:15 -0300
committerMatt Turner <mattst88@gentoo.org>2023-02-22 17:02:48 -0500
commit35256028ffa8fb897da0e13cc529fc0dab9e72dd (patch)
tree74c23120df5e10785cbaead44e3829518c2d0a4c /www-client
parentdev-libs/gjs: Version bump to 1.74.2 (diff)
downloadgentoo-35256028ffa8fb897da0e13cc529fc0dab9e72dd.tar.gz
gentoo-35256028ffa8fb897da0e13cc529fc0dab9e72dd.tar.bz2
gentoo-35256028ffa8fb897da0e13cc529fc0dab9e72dd.zip
www-client/epiphany: Version bump to 43.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29689 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-43.1.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index baa7ea80c408..04e1ca67758f 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-43.0.tar.xz 3890284 BLAKE2B 74a463030bea6489dc05c975fa885ba3e06a3c552f18d29b0579121cf3b04f73fe3c76a6057d9d941f4361732ea1029cd7abb235969ca4f649964e5f909ea2d1 SHA512 56e65c2b3868447b88b89dc97c9d63c4ef1b174334eda15c6ad6b11a38963457df01a6024109ddfaf67730c691e5d68d37abb779604d4719dbc19950d18fe426
+DIST epiphany-43.1.tar.xz 3893416 BLAKE2B 3706b89269a48c7132a8e8a1807345482d16ed87d860974e74c49f2d0bb2dd05b31f9e9c02d4675ccab2b721ffc2f62196a2ca3f3bd5cb52696cf5159465ee5b SHA512 1f54864c35f988b009b739e996dca1735f5222bf9fc5594eed3aa07d673db6f8f8870536b17985c318f39dfac79bce236118d863f9963944bc16cdaec469ca7a
diff --git a/www-client/epiphany/epiphany-43.1.ebuild b/www-client/epiphany/epiphany-43.1.ebuild
new file mode 100644
index 000000000000..caf195038caa
--- /dev/null
+++ b/www-client/epiphany/epiphany-43.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web https://gitlab.gnome.org/GNOME/epiphany"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:0=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=dev-libs/glib-2.67.4:2
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.24.0:3
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.5.0:1=
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.99.4:3.0
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/nettle-3.4:=
+ >=dev-libs/libportal-0.6:0=[gtk]
+ >=dev-db/sqlite-3.22:3
+ >=net-libs/webkit-gtk-2.37.1:4.1=
+
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/43.0-Revert-tests-Set-locale-for-the-encodings-test.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk:4.1[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk:4.1 is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}