summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-03-06 05:22:03 -0800
committerMatt Turner <mattst88@gentoo.org>2017-03-06 05:22:55 -0800
commit9032760dedbfa7635de6687ab0b1e425cf6b4b7a (patch)
treeb96b05730b529b2023b2316391a2811db0fd1045 /x11-drivers/xf86-input-wacom
parentapp-emulation/docker: Add version constraint to containerd/runc versions to a... (diff)
downloadgentoo-9032760dedbfa7635de6687ab0b1e425cf6b4b7a.tar.gz
gentoo-9032760dedbfa7635de6687ab0b1e425cf6b4b7a.tar.bz2
gentoo-9032760dedbfa7635de6687ab0b1e425cf6b4b7a.zip
x11-drivers/xf86-input-wacom: Add support for xorg-server-1.19.
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/files/xf86-input-wacom-0.34.0-xorg-server-1.19-support.patch49
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild4
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/files/xf86-input-wacom-0.34.0-xorg-server-1.19-support.patch b/x11-drivers/xf86-input-wacom/files/xf86-input-wacom-0.34.0-xorg-server-1.19-support.patch
new file mode 100644
index 000000000000..3c1494d3605d
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/files/xf86-input-wacom-0.34.0-xorg-server-1.19-support.patch
@@ -0,0 +1,49 @@
+From f0dedf7a610ac97bc45738492b98ce4f1e0514ec Mon Sep 17 00:00:00 2001
+From: Jason Gerecke <killertofu@gmail.com>
+Date: Wed, 18 Jan 2017 09:00:10 -0800
+Subject: [PATCH] tests: Fix compilation under ABI 25 and greater
+
+The X server recently deprecated xf86BlockSIGIO and xf86UnblockSIGIO and
+simultaneously defined them inline within xf86.h. The new inline definition
+causes problems both because fake-symbols.c will end up redefining them,
+and because the function bodies reference a symbol that does not get included
+when building the tests. To fix these errors, update fake-symbols.c with
+updated include guards and a definition of the undefined symbols.
+
+Signed-off-by: Jason Gerecke <jason.gerecke@wacom.com>
+Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+ test/fake-symbols.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/test/fake-symbols.c b/test/fake-symbols.c
+index 6f2c10a..e649fb9 100644
+--- a/test/fake-symbols.c
++++ b/test/fake-symbols.c
+@@ -493,6 +493,7 @@ void TimerFree(OsTimerPtr timer)
+ {
+ }
+
++#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 24
+ int
+ xf86BlockSIGIO (void)
+ {
+@@ -503,6 +504,15 @@ void
+ xf86UnblockSIGIO (int wasset)
+ {
+ }
++#else
++void input_lock (void)
++{
++}
++
++void input_unlock (void)
++{
++}
++#endif
+
+ /* This is not the same as the X server one, but it'll do for the tests */
+ #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 14
+--
+2.10.2
+
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
index 61c5f062eb9c..202bdb05c930 100644
--- a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
@@ -27,6 +27,10 @@ RDEPEND="dev-libs/libwacom
DEPEND="${RDEPEND}
x11-proto/randrproto"
+PATCHES=(
+ "${FILESDIR}/${P}-xorg-server-1.19-support.patch"
+)
+
pkg_setup() {
linux-info_pkg_setup