summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:28 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:33 +0100
commitb85c9f666d7fc138e8f35f874cd6b5db728bfcac (patch)
tree64ff3687199ba4f1f337d80ec15d3956a83262da /x11-misc
parentdev-haskell/pango: new package, add 0.13.10.0 (diff)
downloadgentoo-b85c9f666d7fc138e8f35f874cd6b5db728bfcac.tar.gz
gentoo-b85c9f666d7fc138e8f35f874cd6b5db728bfcac.tar.bz2
gentoo-b85c9f666d7fc138e8f35f874cd6b5db728bfcac.zip
x11-misc/xmobar: add 0.46
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xmobar/Manifest1
-rw-r--r--x11-misc/xmobar/metadata.xml5
-rw-r--r--x11-misc/xmobar/xmobar-0.46.ebuild86
3 files changed, 92 insertions, 0 deletions
diff --git a/x11-misc/xmobar/Manifest b/x11-misc/xmobar/Manifest
index b3c8e55f3b59..7860d4448776 100644
--- a/x11-misc/xmobar/Manifest
+++ b/x11-misc/xmobar/Manifest
@@ -1 +1,2 @@
DIST xmobar-0.44.1.tar.gz 156756 BLAKE2B bee81627744146989b402ae04d36edb5e4a69686b546457afebad81cda96ece4ce0ace8a2855bd5136610be3fc396c2f62121ea062fffb1ad837145cf3238fdb SHA512 e04f3f9f40ffa4095df2b523916686d93d28b4cbb880f7732cf63d6f1915e721043764b9d723ed8b3c4938c3df749d0e5a9ddb9a9e64a2a015f8f0d6b3f46c97
+DIST xmobar-0.46.tar.gz 168197 BLAKE2B a1b0e94794232641574b0e6c1c55ab8c203fec800702896ab516f2df7d50ffec709385958ffd4098f79ac00a9c88c72c04088bca5f4523501cdb12cf39da8bb5 SHA512 37ebef56c3046b45ec83025ab8233827f50dcc3aa48691e06ac00c59b8bedeafd5860c94e36d54d3f499217a27a12641b0e98f6f0f248b9d56a22d1b103c50c8
diff --git a/x11-misc/xmobar/metadata.xml b/x11-misc/xmobar/metadata.xml
index 85386171573c..bcca3a0444db 100644
--- a/x11-misc/xmobar/metadata.xml
+++ b/x11-misc/xmobar/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="alsa">Use alsa-mixer to get the volume from soundcards.</flag>
+ <flag name="datezone">Enables localized date support.</flag>
<flag name="dbus">Publish a service on the session bus for controlling xmobar.</flag>
<flag name="mpd">MPD support. Needs libmpd installed.</flag>
<flag name="mpris">MPRIS v1, v2 support.</flag>
@@ -17,5 +18,9 @@
<flag name="wifi">Wireless info support via nl80211. Required for the Wireless plugin on systems running Linux, the kernel.</flag>
<flag name="xft">Use Xft to render text. UTF-8 support included.</flag>
<flag name="xpm">Enable usage of xpm for icons.</flag>
+ <flag name="xrender">Use XRender for alpha background pseudo-transparency.</flag>
</use>
+ <upstream>
+ <remote-id type="hackage">xmobar</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/x11-misc/xmobar/xmobar-0.46.ebuild b/x11-misc/xmobar/xmobar-0.46.ebuild
new file mode 100644
index 000000000000..30c801488862
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.46.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -all_extensions,+with_threaded,+with_utf8,-with_iwlib,with_nl80211:wifi,+with_inotify
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="https://codeberg.org/xmobar/xmobar"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="alsa datezone dbus mpd mpris +rtsopts uvmeter +weather wifi xpm +xrender"
+
+RDEPEND=">=dev-haskell/aeson-1.4.7.1:=[profile?]
+ dev-haskell/async:=[profile?]
+ >=dev-haskell/cairo-0.13:=[profile?]
+ >=dev-haskell/colour-2.3.6:=[profile?]
+ >=dev-haskell/extensible-exceptions-0.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ >=dev-haskell/hinotify-0.3:=[profile?] <dev-haskell/hinotify-0.5:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ >=dev-haskell/pango-0.13:=[profile?]
+ >=dev-haskell/parsec-numbers-0.1.0:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?] <dev-haskell/stm-2.6:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/x11-1.6.1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ alsa? (
+ >=dev-haskell/alsa-core-0.5:=[profile?] <dev-haskell/alsa-core-0.6:=[profile?]
+ >=dev-haskell/alsa-mixer-0.3:=[profile?] <dev-haskell/alsa-mixer-0.4:=[profile?]
+ )
+ datezone? ( >=dev-haskell/timezone-olson-0.2:=[profile?] <dev-haskell/timezone-olson-0.3:=[profile?]
+ >=dev-haskell/timezone-series-0.1:=[profile?] <dev-haskell/timezone-series-0.2:=[profile?] )
+ dbus? ( >=dev-haskell/dbus-1:=[profile?] )
+ mpd? ( >=dev-haskell/libmpd-0.9.2.0:=[profile?] )
+ mpris? ( >=dev-haskell/dbus-1:=[profile?] )
+ uvmeter? ( dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] )
+ weather? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] )
+ wifi? ( >=dev-haskell/cereal-0.5.8.1:=[profile?]
+ >=dev-haskell/netlink-1.1.1.0:=[profile?] )
+ xpm? ( x11-libs/libXpm )
+ xrender? ( >=dev-haskell/x11-xft-0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-all_extensions \
+ $(cabal_flag alsa with_alsa) \
+ $(cabal_flag datezone with_datezone) \
+ $(cabal_flag dbus with_dbus) \
+ --flag=with_inotify \
+ --flag=-with_iwlib \
+ $(cabal_flag mpd with_mpd) \
+ $(cabal_flag mpris with_mpris) \
+ $(cabal_flag wifi with_nl80211) \
+ $(cabal_flag rtsopts with_rtsopts) \
+ --flag=with_threaded \
+ --flag=with_utf8 \
+ $(cabal_flag uvmeter with_uvmeter) \
+ $(cabal_flag weather with_weather) \
+ $(cabal_flag xpm with_xpm) \
+ $(cabal_flag xrender with_xrender)
+}
+
+src_install() {
+ cabal_src_install
+
+# dodoc readme.md
+ dodoc etc/xmobar.config etc/xmobar.hs changelog.md
+}