summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/psutil/psutil-5.7.0-r1.ebuild (renamed from dev-python/psutil/psutil-5.7.0.ebuild)11
-rw-r--r--dev-python/psutil/psutil-5.7.2-r1.ebuild (renamed from dev-python/psutil/psutil-5.7.2.ebuild)12
2 files changed, 2 insertions, 21 deletions
diff --git a/dev-python/psutil/psutil-5.7.0.ebuild b/dev-python/psutil/psutil-5.7.0-r1.ebuild
index 2160825ab228..912f00ba6adb 100644
--- a/dev-python/psutil/psutil-5.7.0.ebuild
+++ b/dev-python/psutil/psutil-5.7.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -16,15 +16,6 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linu
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/ipaddress[${PYTHON_USEDEP}]
- ' -2)
- )
-"
-
PATCHES=(
"${FILESDIR}/psutil-5.7.0-tests.patch"
)
diff --git a/dev-python/psutil/psutil-5.7.2.ebuild b/dev-python/psutil/psutil-5.7.2-r1.ebuild
index df39e7ee6d50..9ed14dc9f098 100644
--- a/dev-python/psutil/psutil-5.7.2.ebuild
+++ b/dev-python/psutil/psutil-5.7.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -16,16 +16,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 sparc ~x
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/ipaddress[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- ' -2)
- )
-"
-
PATCHES=(
"${FILESDIR}/psutil-5.7.2-tests.patch"
)