summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-Console_Getargs/Manifest1
-rw-r--r--dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getargs/Manifest b/dev-php/PEAR-Console_Getargs/Manifest
index 93c8bd574194..2558677dcd3a 100644
--- a/dev-php/PEAR-Console_Getargs/Manifest
+++ b/dev-php/PEAR-Console_Getargs/Manifest
@@ -1 +1,2 @@
DIST Console_Getargs-1.3.5.tgz 18207 BLAKE2B d68ea1220700d43a9d7a0844d8659f9e95b377f9a9c609501d0b325083013ac220367c98b545917066e952a8c304703dddf920cdb80c129f222873934895822e SHA512 2e79bfc3947dbce928ae592d825ea16414de147a10f7c41a896d9a557c40a1e83842e39de6e6a78918d91235da73307f84b837a3d049b36cacd202c4b8aa7fd6
+DIST Console_Getargs-1.4.0.tgz 18267 BLAKE2B c0aab73414a0b6dec9818faa2eae4a4f54d70168d089bb64497599e88f4b8ff86e4195e3705a75bece25f6c7d1054759b846be75f7fc749f1d50b4447ad9ec50 SHA512 927777f48599f64e2cdb05b80a473741718493e9efc20988f2993e6b092852f1432e2e9732c1470f7d580fc7e4000d563b7915a94305fe572b7f6dc27da0858e
diff --git a/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild b/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild
new file mode 100644
index 000000000000..58692f2f12eb
--- /dev/null
+++ b/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit php-pear-r2
+
+DESCRIPTION="A command-line arguments parser"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-php/phpunit )"
+
+src_test() {
+ phpunit tests/ || die
+}