summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/acme/acme-9999.ebuild')
-rw-r--r--app-crypt/acme/acme-9999.ebuild29
1 files changed, 21 insertions, 8 deletions
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 1f9364034341..050f571d38f1 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -3,18 +3,28 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=(python{2_7,3_4,3_5})
-EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-inherit git-r3 distutils-r1
+inherit distutils-r1
-DESCRIPTION="An implementation of the ACME protocol"
+MY_PN="letsencrypt"
+MY_PV="${PV/_pre/.dev}"
+MY_P="${MY_PN}-${MY_PV}"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3 distutils-r1
+else
+ SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="An implementation of the Automatic Certificate Management Environment (ACME) protocol"
HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
@@ -27,10 +37,13 @@ RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
-S=${WORKDIR}/${P}/${PN}
+S="${WORKDIR}/${MY_P}/${PN}"
python_test() {
nosetests -w ${PN} || die