summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild b/dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild
index 8d42774fa22e..5b746ecdf792 100644
--- a/dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild
+++ b/dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild
@@ -159,13 +159,14 @@ src_configure() {
}
src_compile() {
- emake -C "${core_build_dir}"
- emake -C "${plugins_build_dir}"
+ # -j1 for bug #902991; it clobbers object files in parallel
+ emake -j1 -C "${core_build_dir}"
+ emake -j1 -C "${plugins_build_dir}"
}
src_install() {
- emake -C "${core_build_dir}" INSTALL_ROOT="${D}" install
- emake -C "${plugins_build_dir}" INSTALL_ROOT="${D}" install
+ emake -j1 -C "${core_build_dir}" INSTALL_ROOT="${D}" install
+ emake -j1 -C "${plugins_build_dir}" INSTALL_ROOT="${D}" install
if use test; then
# remove test artifacts that must not be installed