summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/leatherman')
-rw-r--r--dev-libs/leatherman/Manifest1
-rw-r--r--dev-libs/leatherman/leatherman-1.12.6-r1.ebuild60
-rw-r--r--dev-libs/leatherman/leatherman-1.12.6-r2.ebuild62
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-libs/leatherman/Manifest b/dev-libs/leatherman/Manifest
index 4ac2a94c10d1..d56b570c462e 100644
--- a/dev-libs/leatherman/Manifest
+++ b/dev-libs/leatherman/Manifest
@@ -1,3 +1,2 @@
-DIST leatherman-1.12.6.tar.gz 818106 BLAKE2B 056ea52c355cf178e16be03f2a4fb54bf0e6aece4045545e7e45c50664e711db2bb756f56c9cd33a6dfe1de24c4ecb98766d4bd158ffb7757958274ba38f76db SHA512 4e2a1ee2e7226224f115648a78bc3e4798ef0528ef32e01d1e7ebcbeb1250fd6ed88001c9db21456feeef3bd6ff201b0fd68fd5feb2671a66d13519dd3454386
DIST leatherman-1.12.7.tar.gz 815838 BLAKE2B 21284f5128c9264b751011b1d68c6baf553037612cab39cc339920091ae42980f6c3920f5b339d4cba31a40b190fa73d779f45dcc30b78e866708c3178ac6699 SHA512 dd763bf89d8356aa00805817af7029ee77452a9210b6aded16ac1434f233fbba9b41014ab55a076773f50da6d16e1cffae50e2a23d1c4b336df9cc88c05ede56
DIST leatherman-1.12.8.tar.gz 815817 BLAKE2B b0844527a470c0e54983d49abc84a7331a07f3cac76919f56e58a01d60b794e422f3ef8342e046c483a83c428d2c80ff8e8d6b71375f45ddb03a5721e63c7aef SHA512 c6096a7c0e95fb43c6998f26e8f28157f46b78af4eaf2caaa1caae832d2f23aa7591e3a29a17f24bc9b993421645d37d44249fd8cae15a3d18b40d614acd23ad
diff --git a/dev-libs/leatherman/leatherman-1.12.6-r1.ebuild b/dev-libs/leatherman/leatherman-1.12.6-r1.ebuild
deleted file mode 100644
index 00b2695e08b3..000000000000
--- a/dev-libs/leatherman/leatherman-1.12.6-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A C++ toolkit"
-HOMEPAGE="https://github.com/puppetlabs/leatherman"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 sparc x86"
-IUSE="debug static-libs test"
-#RESTRICT="!test? ( test )"
-RESTRICT="test" # restricted til we don't need the shared_nowide patch
-
-RDEPEND="dev-libs/boost:=[nls]
- net-misc/curl"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/portage-sandbox-test-fix.patch
- "${FILESDIR}"/1.12.2-shared_nowide.patch
-)
-
-src_prepare() {
- sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
- # vendored boost lib conflicts with boost 1.73 and above
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DLEATHERMAN_ENABLE_TESTING=$(usex test)
- # We depend on Boost with nls, so this is always true
- -DLEATHERMAN_USE_ICU=ON
-
- -DLEATHERMAN_SHARED=$(usex !static-libs)
- )
-
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
-
- cmake_src_configure
-}
-
-src_test() {
- "${WORKDIR}/${P}"_build/bin/leatherman_test || die
-}
-
-src_install() {
- cmake_src_install
-}
diff --git a/dev-libs/leatherman/leatherman-1.12.6-r2.ebuild b/dev-libs/leatherman/leatherman-1.12.6-r2.ebuild
deleted file mode 100644
index 94708b8922ab..000000000000
--- a/dev-libs/leatherman/leatherman-1.12.6-r2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A C++ toolkit"
-HOMEPAGE="https://github.com/puppetlabs/leatherman"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug static-libs test"
-#RESTRICT="!test? ( test )"
-RESTRICT="test" # restricted til we don't need the shared_nowide patch
-
-RDEPEND="dev-libs/boost:=[nls]
- net-misc/curl"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/portage-sandbox-test-fix.patch
- "${FILESDIR}"/1.12.2-shared_nowide.patch
-)
-
-src_prepare() {
- sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
- # vendored boost lib conflicts with boost 1.73 and above
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DLEATHERMAN_ENABLE_TESTING=$(usex test)
- # We depend on Boost with nls, so this is always true
- -DLEATHERMAN_USE_ICU=ON
-
- -DLEATHERMAN_SHARED=$(usex !static-libs)
- )
-
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
-
- cmake_src_configure
- cd "${BUILD_DIR}"
- eapply "${FILESDIR}"/${P}-SIGSTKSZ.patch
-}
-
-src_test() {
- "${WORKDIR}/${P}"_build/bin/leatherman_test || die
-}
-
-src_install() {
- cmake_src_install
-}