summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Class-Load')
-rw-r--r--dev-perl/Class-Load/Class-Load-0.250.0.ebuild37
-rw-r--r--dev-perl/Class-Load/Manifest1
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Class-Load/Class-Load-0.250.0.ebuild b/dev-perl/Class-Load/Class-Load-0.250.0.ebuild
new file mode 100644
index 000000000000..6f499e7f30b3
--- /dev/null
+++ b/dev-perl/Class-Load/Class-Load-0.250.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="A working (require q{Class::Name}) and more"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# uses Scalar-Util
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Data-OptList-0.110.0
+ virtual/perl-Exporter
+ >=dev-perl/Module-Implementation-0.40.0
+ >=dev-perl/Module-Runtime-0.12.0
+ >=dev-perl/Package-Stash-0.140.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ dev-perl/Test-Needs
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-version
+ )
+"
diff --git a/dev-perl/Class-Load/Manifest b/dev-perl/Class-Load/Manifest
index 0f0e4123762a..a06af869058a 100644
--- a/dev-perl/Class-Load/Manifest
+++ b/dev-perl/Class-Load/Manifest
@@ -1 +1,2 @@
DIST Class-Load-0.24.tar.gz 35412 BLAKE2B da000f18dc81641c28027bfaafd3cbea758356c5e2af5204c9b818b51fd51239432793a0b26605d0cce70af03ef28bbcf87b50b6cb9056a38cc04feb05adcc08 SHA512 42459727fc622334336aedaa49e3dfd1aa92103c838a33b30ac61d9d9fe74512f7b1012b3c20fd1c4eaab1456545feab4d9d22b91162ecddd4683defc1b987eb
+DIST Class-Load-0.25.tar.gz 36644 BLAKE2B b28f559a0d582f1f48cf8e158065d86b764b6271df0f9f4df7b7ec97317ad1d6a3154d476c5a8387219d56fdcceea3c853706c2cccbcf6d247b47381fa5de3d2 SHA512 feacb4ae99358d3dc45b23b2d7cc814603e59a72424e7e0620d4939fa6d6206a1bb123c010b49013ce4764df11dc7c04fc1d7bd5783c61a391310bcb653e7ca4