summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-6.0.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 9ad581f6ac93..f936425c082b 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,2 +1,3 @@
DIST apispec-6.0.0.gh.tar.gz 72200 BLAKE2B c65278602c7f05074bf6e4e36a5e7aeaf0eabcc281c387448666f6958eef95a4f4f297055f58eb580169249cc90c1643bcdef0f9281792e4840d719cc921c9f3 SHA512 4c4c34554241fba67d0aad41aa81e5c6e97ee42003da503afa223ff5fbf0046a8b5f3dc3835fe9ae1dc03181f4be5fabae1a7d80871c0a061602d2593315b2db
DIST apispec-6.0.1.gh.tar.gz 72293 BLAKE2B cc5bc094965bc8ce7b9f4de6292aeaaf9a873c12841230f53c32e0e732fbced0e8d02461bef8cf3bde5d715c63edd697d6c3429f4a27e767b31a1ba101dc5aaa SHA512 fabe14511a1dd598101977bcab70e5bdb1338f219f348f9584062d0c4c80de8adc1eb7f5e202a6a9d1e3fa11d775de2871f238585f6b6471bebdb3fe47bf0dc0
+DIST apispec-6.0.2.gh.tar.gz 72472 BLAKE2B 0ff39ad92648cd63487f8901dc918fc1c642ce677ef73d5a7c849cdafbf7c81ac3ec51224575cd83c060930c1b2ef0ebfb3e94e1fb30f040e4dc4aa2bd221936 SHA512 aa5e2cc41d5b3c4555da929819135df30192e6f6ff08518d62674495f0d28c14e51a0aa111b289e5f9d7205f821c1fd4e28b914899ea3e15b3e20f6052258117
diff --git a/dev-python/apispec/apispec-6.0.2.ebuild b/dev-python/apispec/apispec-6.0.2.ebuild
new file mode 100644
index 000000000000..82bb02125050
--- /dev/null
+++ b/dev-python/apispec/apispec-6.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}