summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpydoc/numpydoc-0.4-r1.ebuild')
-rw-r--r--dev-python/numpydoc/numpydoc-0.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/numpydoc/numpydoc-0.4-r1.ebuild b/dev-python/numpydoc/numpydoc-0.4-r1.ebuild
new file mode 100644
index 000000000000..9679b9d64bac
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-0.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="https://pypi.python.org/pypi/numpydoc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ chmod -R a+r *.egg-info || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Tests are written only for py2m pypy
+ if ! python_is_python3; then
+ nosetests || die "Testing failed with ${EPYTHON}"
+ fi
+}