summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest1
-rw-r--r--dev-python/pyopenssl/pyopenssl-20.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index ea84bd5c37d1..16ba5b7fa694 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1 +1,2 @@
DIST pyOpenSSL-19.1.0.tar.gz 160510 BLAKE2B e6e39f860221a2696aa3fa32ac89ed48e34b18e4accc366a86264d943a15a1b00ba1a0d8349550d1775d25836aa5d214e1e3fe4ec0a9c0f6d5ab00cd9fede633 SHA512 4acd96f287d72eb11bd812697d28cd6eb6a96a4653248b65f967187830a6b17cc1254775a18a3405469f3d45abdae6f02d165f2f35f035f3174c2826fba82916
+DIST pyOpenSSL-20.0.0.tar.gz 173786 BLAKE2B 3fb1e90e20b3e083fc93f6dc8a54fb54e15ceb38c4d2e84e2d7d68bb56f9e3828cd264e3554f25465e858687e74a7f20b91216fb7a0b4b2c656ea86423cd3442 SHA512 26e8a64d53a35434ad4bf5ef50ed5c37d7b92b0db971a2103dcafea56a0b377d67333af630a31405a97cf2cffddde320907b4950ed336a8321391854bcd2c50a
diff --git a/dev-python/pyopenssl/pyopenssl-20.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-20.0.0.ebuild
new file mode 100644
index 000000000000..b09f1b1bdec6
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-20.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ https://www.pyopenssl.org/
+ https://pypi.org/project/pyOpenSSL/
+ https://github.com/pyca/pyopenssl/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # Requires network access
+ sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ TZ=UTC pytest -vv || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
+}