summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/meson')
-rw-r--r--dev-util/meson/meson-0.48.2.ebuild12
-rw-r--r--dev-util/meson/meson-0.49.0.ebuild12
-rw-r--r--dev-util/meson/meson-9999.ebuild12
3 files changed, 33 insertions, 3 deletions
diff --git a/dev-util/meson/meson-0.48.2.ebuild b/dev-util/meson/meson-0.48.2.ebuild
index 07742ab26563..1b7da1e7a772 100644
--- a/dev-util/meson/meson-0.48.2.ebuild
+++ b/dev-util/meson/meson-0.48.2.ebuild
@@ -12,7 +12,7 @@ else
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x64-macos ~x64-solaris"
fi
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Open source build system"
HOMEPAGE="http://mesonbuild.com/"
@@ -32,6 +32,16 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+src_test() {
+ if tc-is-gcc; then
+ # LTO fails for static libs because the bfd plugin in missing.
+ # Remove this workaround after sys-devel/gcc-config-2.0 is stable.
+ # https://bugs.gentoo.org/672706
+ tc-getPROG AR gcc-ar >/dev/null
+ fi
+ distutils-r1_src_test
+}
+
python_test() {
(
# test_meson_installed
diff --git a/dev-util/meson/meson-0.49.0.ebuild b/dev-util/meson/meson-0.49.0.ebuild
index 9605fa9af90c..5e725b324a15 100644
--- a/dev-util/meson/meson-0.49.0.ebuild
+++ b/dev-util/meson/meson-0.49.0.ebuild
@@ -12,7 +12,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-macos ~x64-solaris"
fi
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Open source build system"
HOMEPAGE="http://mesonbuild.com/"
@@ -32,6 +32,16 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+src_test() {
+ if tc-is-gcc; then
+ # LTO fails for static libs because the bfd plugin in missing.
+ # Remove this workaround after sys-devel/gcc-config-2.0 is stable.
+ # https://bugs.gentoo.org/672706
+ tc-getPROG AR gcc-ar >/dev/null
+ fi
+ distutils-r1_src_test
+}
+
python_test() {
(
# test_meson_installed
diff --git a/dev-util/meson/meson-9999.ebuild b/dev-util/meson/meson-9999.ebuild
index 9605fa9af90c..5e725b324a15 100644
--- a/dev-util/meson/meson-9999.ebuild
+++ b/dev-util/meson/meson-9999.ebuild
@@ -12,7 +12,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-macos ~x64-solaris"
fi
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Open source build system"
HOMEPAGE="http://mesonbuild.com/"
@@ -32,6 +32,16 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+src_test() {
+ if tc-is-gcc; then
+ # LTO fails for static libs because the bfd plugin in missing.
+ # Remove this workaround after sys-devel/gcc-config-2.0 is stable.
+ # https://bugs.gentoo.org/672706
+ tc-getPROG AR gcc-ar >/dev/null
+ fi
+ distutils-r1_src_test
+}
+
python_test() {
(
# test_meson_installed