summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/qgit')
-rw-r--r--dev-vcs/qgit/Manifest1
-rw-r--r--dev-vcs/qgit/qgit-2.10.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-vcs/qgit/Manifest b/dev-vcs/qgit/Manifest
index 236635a670ae..5508e84f555f 100644
--- a/dev-vcs/qgit/Manifest
+++ b/dev-vcs/qgit/Manifest
@@ -1 +1,2 @@
+DIST qgit-2.10.tar.gz 222085 BLAKE2B cfff7fae9aa736a977ec56d84c695527468002ea345e2d467283ad219285a0250f239612457499ed26c04685124782b644e59ae97a24f314747c494544a3a78b SHA512 a81a3cb3c5521a1b8cec78dd428f71217bdeeba34375ce188b3c073e131cacd773fc5f40824251491f11a702db729cceb06b291295e2769435b76937acbfdfa0
DIST qgit-2.9.tar.gz 263875 BLAKE2B 8ec1235c760f2473a0700e7033ab99f3e72f019dee47761b86999a7de173132cf6592e9f5652b68285cd126adc4efffb5688944f34be2686683727354ab041c5 SHA512 2c91e02d0a7ea1e4620882520c77b47ff9b28fb9c9f9d178bf98b3e728e600e8d86a9e6e4cd60c33dbe63ced3636934fb7cdd6b0d5fa58182873675e3f97cc33
diff --git a/dev-vcs/qgit/qgit-2.10.ebuild b/dev-vcs/qgit/qgit-2.10.ebuild
new file mode 100644
index 000000000000..f593607c918c
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Qt GUI for git repositories"
+HOMEPAGE="https://github.com/tibirna/qgit"
+SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+DOCS=( README.adoc )