summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/openclonk/openclonk-7.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/games-action/openclonk/openclonk-7.0.ebuild b/games-action/openclonk/openclonk-7.0.ebuild
index be62f00e1f8c..dd0d3d826bc8 100644
--- a/games-action/openclonk/openclonk-7.0.ebuild
+++ b/games-action/openclonk/openclonk-7.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils eutils gnome2-utils python-any-r1 fdo-mime games
+inherit cmake-utils eutils gnome2-utils python-any-r1 fdo-mime toolchain-funcs games
MY_P=${PN}-release-${PV}-src
@@ -43,6 +43,7 @@ RDEPEND="
)
dedicated? ( sys-libs/readline:0= )"
DEPEND="${RDEPEND}
+ || ( >=sys-devel/gcc-4.9 >=sys-devel/clang-3.3 )
virtual/pkgconfig
doc? (
${PYTHON_DEPS}
@@ -56,6 +57,14 @@ PATCHES=(
)
S=${WORKDIR}/${P}-src
+pkg_pretend() {
+ if [[ $(tc-getCXX) == *g++* && $(gcc-version) < 4.9 ]] ; then
+ die 'The active compiler needs to be gcc 4.9 (or newer) or clang'
+ else
+ einfo 'The active compiler should be ok'
+ fi
+}
+
pkg_setup() {
games_pkg_setup
use doc && python-any-r1_pkg_setup