summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gnomad')
-rw-r--r--media-sound/gnomad/files/gnomad-2.9.6-fno-common.patch56
-rw-r--r--media-sound/gnomad/gnomad-2.9.6.ebuild15
2 files changed, 66 insertions, 5 deletions
diff --git a/media-sound/gnomad/files/gnomad-2.9.6-fno-common.patch b/media-sound/gnomad/files/gnomad-2.9.6-fno-common.patch
new file mode 100644
index 000000000000..76abaa9cfa2d
--- /dev/null
+++ b/media-sound/gnomad/files/gnomad-2.9.6-fno-common.patch
@@ -0,0 +1,56 @@
+--- a/src/common.h
++++ b/src/common.h
+@@ -130,25 +130,25 @@
+ } playlist_widgets_t;
+
+ /* Globally known widgets */
+-transfer_widgets_t transfer_widgets;
+-data_widgets_t data_widgets;
+-playlist_widgets_t playlist_widgets;
++extern transfer_widgets_t transfer_widgets;
++extern data_widgets_t data_widgets;
++extern playlist_widgets_t playlist_widgets;
+
+ /* Global progress bar - not so good but... */
+-GtkWidget *progress_bar;
++extern GtkWidget *progress_bar;
+
+ /* Global playlist selection for the popup, not good either ... */
+-GList *jukebox_playlist;
+-GList *selected_target_playlists;
++extern GList *jukebox_playlist;
++extern GList *selected_target_playlists;
+
+ /* Global lock variable for the jukebox */
+-gboolean volatile jukebox_locked;
++extern gboolean volatile jukebox_locked;
+
+ /* Global cancellation variable for jukebox operations */
+-gboolean volatile cancel_jukebox_operation;
++extern gboolean volatile cancel_jukebox_operation;
+
+ /* Global debug level variable (standard = 7) */
+-gint gnomad_debug;
++extern gint gnomad_debug;
+
+ /* A proc for hiding dialog windows */
+ GCallback dispose_of_dialog_window(GtkButton * button, gpointer data);
+--- a/src/gnomad2.c
++++ b/src/gnomad2.c
+@@ -34,6 +34,16 @@
+ guint uevent_device_hooked = 0;
+ #endif
+
++transfer_widgets_t transfer_widgets;
++data_widgets_t data_widgets;
++playlist_widgets_t playlist_widgets;
++GtkWidget *progress_bar;
++GList *jukebox_playlist;
++GList *selected_target_playlists;
++gboolean volatile jukebox_locked;
++gboolean volatile cancel_jukebox_operation;
++gint gnomad_debug;
++
+ /* This one should be global really */
+ GtkWidget *main_window;
+
diff --git a/media-sound/gnomad/gnomad-2.9.6.ebuild b/media-sound/gnomad/gnomad-2.9.6.ebuild
index fb2ee99ca369..45206c12519c 100644
--- a/media-sound/gnomad/gnomad-2.9.6.ebuild
+++ b/media-sound/gnomad/gnomad-2.9.6.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
MY_PN=${PN}2
MY_P=${MY_PN}-${PV}
-DESCRIPTION="A GTK+ music manager and swiss army knife for the Portable Digital Entertainment (PDE) protocol"
+DESCRIPTION="A GTK+ music manager for the Portable Digital Entertainment (PDE) protocol"
HOMEPAGE="http://gnomad2.sourceforge.net/"
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
@@ -22,12 +22,17 @@ RDEPEND="
media-libs/libnjb
media-libs/taglib
>=x11-libs/gtk+-2.24:2"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
- nls? ( dev-util/intltool sys-devel/gettext )"
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${PN}-2.9.6-fno-common.patch )
DOCS=( AUTHORS README TODO ) # ChangeLog and NEWS are both outdated
src_configure() {