summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/tsmuxer')
-rw-r--r--media-video/tsmuxer/Manifest2
-rw-r--r--media-video/tsmuxer/metadata.xml14
-rw-r--r--media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild78
3 files changed, 94 insertions, 0 deletions
diff --git a/media-video/tsmuxer/Manifest b/media-video/tsmuxer/Manifest
new file mode 100644
index 000000000000..0d242200f6f9
--- /dev/null
+++ b/media-video/tsmuxer/Manifest
@@ -0,0 +1,2 @@
+DIST tsMuxeR_shared_1.10.6.tar.gz 640010 SHA256 40871629da0968488c90600a0870b6f9e3ed09d30522c56a97d7397365af0910 SHA512 64d5214a84ae1d2fdbaad214ff9586007ed1d88e7d0e18d866dfe4e75cf371de52e4c05eb1d67d0b9c7c2f9cd5ca87b4dbb2b113e81361ba658aa1fecca115d6 WHIRLPOOL ca4993cf04a22051f9a5c8b7cbe8537156263d2b3e0c9f27a889a519eb7b171df7dbca5841a7345237b1623ce46c547ace886ce07bba3e92717513f87fd1cd15
+DIST tsmuxer-icon.png 1634 SHA256 ff166c09d7e5218ee566d876c20873e26ccf6242a3f37a7f01e6514c4396a753 SHA512 4af3b1bd0e1a2c8379773e16121aa1c0ae749a3a9b9fdef0622991ea4ea632f51fbd91af0f6b5a415c28b375bd71adde2e9aacfb8b495242168cc97e1c8bf4ff WHIRLPOOL 265eed8149ce9de8e8695bdc8a4e726cdb4cf4514f30263384d60edcfb896b37fc8cfdb707b16d11672cb302f8300f8790415db3f6b4ced11dd4d5bcd4859b96
diff --git a/media-video/tsmuxer/metadata.xml b/media-video/tsmuxer/metadata.xml
new file mode 100644
index 000000000000..bdb0715913b9
--- /dev/null
+++ b/media-video/tsmuxer/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <longdescription lang="en">
+ SmartLabs tsMuxeR - the software utility to create TS and M2TS files for
+ IP broadcasting as well as for viewing at hardware video players (i.e.,
+ Dune HD Ultra, Sony Playstation3 and others). tsMuxeR is a part of
+ SmartCONTENT, content preparation solution.
+ </longdescription>
+ <use>
+ <flag name='qt4'>Installs tsMuxerGUI (needs Qt4)</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild b/media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild
new file mode 100644
index 000000000000..a26173b63670
--- /dev/null
+++ b/media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils base qt4-r2
+
+DESCRIPTION="Utility to create and demux TS and M2TS files"
+HOMEPAGE="http://www.smlabs.net/en/products/tsmuxer/"
+SRC_URI="http://www.smlabs.net/tsMuxer/tsMuxeR_shared_${PV}.tar.gz
+ http://gentoo.sbriesen.de/distfiles/tsmuxer-icon.png"
+LICENSE="SmartLabs"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4 linguas_ru"
+
+QA_FLAGS_IGNORED="opt/${PN}/bin/tsMuxeR opt/${PN}/bin/tsMuxerGUI"
+
+DEPEND="|| (
+ >=app-arch/upx-ucl-3.01
+ >=app-arch/upx-bin-3.01
+)"
+RDEPEND="
+ x86? (
+ media-libs/freetype:2
+ qt4? (
+ dev-libs/glib:2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/fontconfig
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ )
+ )
+ amd64? (
+ >=media-libs/freetype-2.5.0.1:2[abi_x86_32(-)]
+ qt4? (
+ >=dev-libs/glib-2.34.3:2[abi_x86_32(-)]
+ >=dev-qt/qtcore-4.8.5-r1:4[abi_x86_32(-)]
+ >=dev-qt/qtgui-4.8.5-r2:4[abi_x86_32(-)]
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ >=media-libs/libpng-1.2.51:1.2[abi_x86_32(-)]
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=x11-libs/libICE-1.0.8-r1[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
+ )
+ )"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ upx -d tsMuxeR tsMuxerGUI || die
+}
+
+src_install() {
+ dodir /opt/bin
+ exeinto /opt/${PN}/bin
+
+ doexe tsMuxeR
+ dosym ../${PN}/bin/tsMuxeR /opt/bin/tsMuxeR
+
+ if use qt4; then
+ doexe tsMuxerGUI
+ dosym ../${PN}/bin/tsMuxerGUI /opt/bin/tsMuxerGUI
+ newicon "${DISTDIR}/${PN}-icon.png" "${PN}.png"
+ make_desktop_entry tsMuxerGUI "tsMuxeR GUI" "${PN}" "Qt;AudioVideo;Video"
+ fi
+
+ use linguas_ru && dodoc readme.rus.txt
+}