summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.218_p5.ebuild5
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.219_p1.ebuild3
2 files changed, 5 insertions, 3 deletions
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.218_p5.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.218_p5.ebuild
index c2ded9744780..6de6a5851681 100644
--- a/net-analyzer/openbsd-netcat/openbsd-netcat-1.218_p5.ebuild
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.218_p5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -47,7 +47,8 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ # gnu99 for bug #943711
+ emake CC="$(tc-getCC) -std=gnu99" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.219_p1.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.219_p1.ebuild
index d07c4bf17e73..3b971fe91184 100644
--- a/net-analyzer/openbsd-netcat/openbsd-netcat-1.219_p1.ebuild
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.219_p1.ebuild
@@ -47,7 +47,8 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # gnu99 for bug #943711
+ emake CC="$(tc-getCC) -std=gnu99" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
}
src_install() {