summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild
new file mode 100644
index 000000000000..fa15b39c96c1
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}