summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild')
-rw-r--r--ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild b/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild
new file mode 100644
index 000000000000..ff07eb121aa4
--- /dev/null
+++ b/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+ROS_PN="ament_cmake"
+DESCRIPTION="The entry point package for the ament buildsystem in CMake"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_export_definitions[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_export_dependencies[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_export_include_directories[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_export_interfaces[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_export_libraries[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_export_link_flags[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_libraries[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_python[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_target_dependencies[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_test[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_version[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+
+src_configure() {
+ # This is a build tool that does not install python-related files
+ # ... but we need to propagate the deps and use python3 to build it.
+ local pyimpl="${PYTHON_COMPAT[0]}"
+ python_export "${pyimpl}" EPYTHON PYTHON
+ python_wrapper_setup
+ cmake-utils_src_configure
+}