summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/pwdb/files/pwdb-0.62-disable-static.patch19
-rw-r--r--sys-libs/pwdb/pwdb-0.62-r2.ebuild5
2 files changed, 23 insertions, 1 deletions
diff --git a/sys-libs/pwdb/files/pwdb-0.62-disable-static.patch b/sys-libs/pwdb/files/pwdb-0.62-disable-static.patch
new file mode 100644
index 000000000000..a3395e169079
--- /dev/null
+++ b/sys-libs/pwdb/files/pwdb-0.62-disable-static.patch
@@ -0,0 +1,19 @@
+--- a/libpwdb/Makefile
++++ b/libpwdb/Makefile
+@@ -46,7 +46,7 @@
+ %.o : %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(DYNAMIC) $(CPPFLAGS) $(TARGET_ARCH) -c $< -o $@
+
+-all: $(LIBSTATIC) $(LIBDYNAME)
++all: $(LIBDYNAME)
+
+
+ $(LIBDYNAME): $(LIBOBJ)
+@@ -70,7 +70,6 @@
+ $(INSTALL) -m 755 $(LIBFILENAME) $(LIBDIR)
+ ln -sf $(LIBFILENAME) $(LIBDIR)/$(LIBSONAME)
+ ln -sf $(LIBFILENAME) $(LIBDIR)/$(LIBDYNAME)
+- $(INSTALL) -m 644 $(LIBSTATIC) $(LIBDIR)
+
+ clean:
+ @rm -f *.so *.a core a.out `find . -name "*.o" -print` `find . -name "*~" -print`
diff --git a/sys-libs/pwdb/pwdb-0.62-r2.ebuild b/sys-libs/pwdb/pwdb-0.62-r2.ebuild
index 6701f44fdb0a..d44cdd852dd0 100644
--- a/sys-libs/pwdb/pwdb-0.62-r2.ebuild
+++ b/sys-libs/pwdb/pwdb-0.62-r2.ebuild
@@ -26,7 +26,10 @@ BDEPEND="virtual/pkgconfig"
DOCS=( CHANGES CREDITS README doc/pwdb.txt )
HTML_DOCS=( doc/html/. )
-PATCHES=( "${FILESDIR}"/${P}-build.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-disable-static.patch # bug 725972
+)
src_prepare() {
default