summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.26.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index cfc332d20f08..e712c8f0eb8c 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.25.tar.gz 689178 BLAKE2B 4cc8d7ae2aa399c031dadd031e7711a71f73402e5f7e4678fcccc826d5992c2cf08ed009a62ae01ea500de2a63da187ed609aab4128c5054da86e173252f0c85 SHA512 1934e9ec435a8e19cbb0f45dbca5106911e53755d6581f8ca89058bffdc50085f3e0f6ab092ea76a7c203689474fbb81f9d20d8e5fd452bc6b855046f10b85a5
+DIST mod_h2-2.0.26.tar.gz 689313 BLAKE2B 472fed8dea63519c8bcf747a22d2cf081dd13180245925095bcc2e7a5c9764ed51235496f351d87fb6975d4d24f069c7fc93cf02ea42aebf6cf57dc6e33c5162 SHA512 73230bae718057e201a2580bdf28b2263637b52f414c2f6abf8e97f3b11472b649edd95c8c956a12473b567edd8e8a7eb5acf91f85621a7128a132f4891f9703
diff --git a/www-apache/mod_h2/mod_h2-2.0.26.ebuild b/www-apache/mod_h2/mod_h2-2.0.26.ebuild
new file mode 100644
index 000000000000..dddc92e83e4f
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.26.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}