From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 dev-util/omake/omake-0.9.8.6.0_rc1.ebuild | 82 +++++++++++++++++++++++++++++++
 1 file changed, 82 insertions(+)
 create mode 100644 dev-util/omake/omake-0.9.8.6.0_rc1.ebuild

(limited to 'dev-util/omake/omake-0.9.8.6.0_rc1.ebuild')

diff --git a/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild b/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild
new file mode 100644
index 000000000000..b39cf8b8b7bd
--- /dev/null
+++ b/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs multilib versionator eutils
+
+MY_PV=$(replace_version_separator 5 '.' "$(replace_version_separator 4 '-' )")
+RESTRICT="installsources"
+DESCRIPTION="Make replacement"
+HOMEPAGE="http://omake.metaprl.org/"
+SRC_URI="http://omake.metaprl.org/downloads/${PN}-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="doc fam ncurses +ocamlopt readline"
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+	ncurses? ( >=sys-libs/ncurses-5.3 )
+	fam? ( virtual/fam )
+	readline? ( >=sys-libs/readline-4.3 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-${MY_PV%-*}
+
+use_boolean() {
+	if use $1; then
+		echo "true"
+	else
+		echo "false"
+	fi
+}
+
+src_prepare() {
+	epatch \
+		"${FILESDIR}/${P}-cflags.patch" \
+		"${FILESDIR}/${P}-warnerror.patch"
+}
+
+src_configure() {
+	# Configuration steps...
+	echo "PREFIX = \$(dir \$\"/usr\")" > .config
+	echo "BINDIR = \$(dir \$\"\$(PREFIX)/bin\")" >> .config
+	echo "LIBDIR = \$(dir \$\"\$(PREFIX)/$(get_libdir)\")" >> .config
+	echo "MANDIR = \$(dir \$\"\$(PREFIX)/man\")" >> .config
+
+	echo "CC = $(tc-getCC)" >> .config
+	echo "CFLAGS = ${CFLAGS}" >> .config
+
+	if use ocamlopt; then
+		echo "NATIVE_ENABLED = true" >> .config
+		echo "BYTE_ENABLED = false" >> .config
+	else
+		echo "NATIVE_ENABLED = false" >> .config
+		echo "BYTE_ENABLED = true" >> .config
+	fi
+
+	echo "NATIVE_PROFILE = false" >> .config
+
+	echo "READLINE_ENABLED = $(use_boolean readline)" >> .config
+	echo "FAM_ENABLED = $(use_boolean fam)" >> .config
+	echo "NCURSES_ENABLED = $(use_boolean ncurses)" >> .config
+
+	echo "DEFAULT_SAVE_INTERVAL = 60" >> .config
+
+	echo "OCAMLDEP_MODULES_ENABLED = false" >> .config
+}
+
+src_compile() {
+	emake all
+}
+
+src_install() {
+	emake INSTALL_ROOT="${D}" install
+	dodoc CHANGELOG.txt
+	if use doc; then
+		dodoc doc/ps/omake-doc.{pdf,ps} doc/txt/omake-doc.txt
+		dohtml -r doc/html/*
+	fi
+	use ocamlopt || export STRIP_MASK="*/bin/*"
+}
-- 
cgit v1.2.3-65-gdbad