From bd1059b851ca8d9a3b269d3b2be28e44d931155b Mon Sep 17 00:00:00 2001
From: Jimi Huotari <chiitoo@gentoo.org>
Date: Thu, 9 Nov 2023 21:25:58 +0200
Subject: lxqt-base/lxqt-powermanagement: add 1.4.0

Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
---
 lxqt-base/lxqt-powermanagement/Manifest            |  1 +
 .../lxqt-powermanagement-1.4.0.ebuild              | 51 ++++++++++++++++++++++
 2 files changed, 52 insertions(+)
 create mode 100644 lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.4.0.ebuild

(limited to 'lxqt-base')

diff --git a/lxqt-base/lxqt-powermanagement/Manifest b/lxqt-base/lxqt-powermanagement/Manifest
index 2c86f57baab1..948835afdff7 100644
--- a/lxqt-base/lxqt-powermanagement/Manifest
+++ b/lxqt-base/lxqt-powermanagement/Manifest
@@ -1 +1,2 @@
 DIST lxqt-powermanagement-1.3.0.tar.xz 91852 BLAKE2B 28deb2120974a000333bba6bc5b9922abb40f2fd0efde07d8a8cf32c2c7172e796107f4b0c3a9332ff4f179fb02a2ecd7e856dfd746d85eaf8a627ce897c2e7c SHA512 79891ba791a167c8b4b27acd309908b0badafcf273aca880c4db592b776d8672d240bc8d4a9552cb83195a9a9929e5b1722a6d20be3ea810c3dcb61dc83fd323
+DIST lxqt-powermanagement-1.4.0.tar.xz 93280 BLAKE2B 2df04ecdbeeddbc3dba41d115878605091511a09fdd494fcb979e7ddf73e7a51b428be7120d30a4ea690f612afb1f4185b863b80bd96e56897249f22ba6e60a7 SHA512 20b6b541fbf0eda1471af233f09744861428d74743b248b95be27c82a3d6fa1c71bfb7f4b5ff7a5408a37a6975a831b525290e8ec012e3546b0e69dfe63ccf7c
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.4.0.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.4.0.ebuild
new file mode 100644
index 000000000000..cf70d933a82a
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="LXQt daemon for power management and auto-suspend"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == *9999* ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+	SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+	KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+	>=dev-qt/linguist-tools-5.15:5
+	>=dev-util/lxqt-build-tools-0.13.0
+	virtual/pkgconfig
+"
+DEPEND="
+	>=dev-libs/libqtxdg-3.11.0
+	>=dev-qt/qtcore-5.15:5
+	>=dev-qt/qtdbus-5.15:5
+	>=dev-qt/qtgui-5.15:5
+	>=dev-qt/qtsvg-5.15:5
+	>=dev-qt/qtwidgets-5.15:5
+	kde-frameworks/kwindowsystem:5
+	kde-frameworks/kidletime:5
+	kde-frameworks/solid:5
+	=lxqt-base/liblxqt-${MY_PV}*:=
+	=lxqt-base/lxqt-globalkeys-${MY_PV}*
+	sys-power/upower
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+	xdg_icon_cache_update
+}
+
+pkg_postrm() {
+	xdg_icon_cache_update
+}
-- 
cgit v1.2.3-65-gdbad