From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 media-libs/lv2/lv2-1.8.0.ebuild | 44 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
 create mode 100644 media-libs/lv2/lv2-1.8.0.ebuild

(limited to 'media-libs/lv2/lv2-1.8.0.ebuild')

diff --git a/media-libs/lv2/lv2-1.8.0.ebuild b/media-libs/lv2/lv2-1.8.0.ebuild
new file mode 100644
index 000000000000..1db4e5ad4d58
--- /dev/null
+++ b/media-libs/lv2/lv2-1.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-single-r1 waf-utils
+
+DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
+HOMEPAGE="http://lv2plug.in/"
+SRC_URI="http://lv2plug.in/spec/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc plugins"
+
+DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
+RDEPEND="${DEPEND}
+	dev-python/lxml[${PYTHON_USEDEP}]
+	dev-python/pygments[${PYTHON_USEDEP}]
+	dev-python/rdflib[${PYTHON_USEDEP}]
+	!<media-libs/slv2-0.4.2
+	!media-libs/lv2core
+	!media-libs/lv2-ui"
+DEPEND="${DEPEND}
+	plugins? ( virtual/pkgconfig )
+	doc? ( app-doc/doxygen dev-python/rdflib )"
+DOCS=( "README" "NEWS" )
+
+src_configure() {
+	waf-utils_src_configure \
+		--docdir="${EPREFIX}"/usr/share/doc/${PF} \
+		$(use plugins || echo " --no-plugins") \
+		$(use doc     && echo " --docs"      )
+}
+
+src_install() {
+	waf-utils_src_install
+
+	python_fix_shebang "${D}"
+}
-- 
cgit v1.2.3-65-gdbad