From cb1572313ce54913b44c5849bbed23de33d94e10 Mon Sep 17 00:00:00 2001
From: Ionen Wolkens <ionen@gentoo.org>
Date: Tue, 11 Oct 2022 04:26:00 -0400
Subject: sci-calculators/hexcalc: pass -std=gnu89

Does not build with `clang -std=c2x`, early workaround for
when this will become a default.

(not actively hunting for these, merely revisiting packages
previously looked at for clang16 even if not an issue "yet").

Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
---
 sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

(limited to 'sci-calculators/hexcalc')

diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
index 20e117cd6853..729630099a29 100644
--- a/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
@@ -3,7 +3,7 @@
 
 EAPI=8
 
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
 
 DESCRIPTION="Simple hex calculator for X"
 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -32,6 +32,8 @@ PATCHES=(
 )
 
 src_configure() {
+	append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
 	CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
 		IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
 }
-- 
cgit v1.2.3-65-gdbad