From d478be8693d90d80df9c2a693b8625e30a8cd160 Mon Sep 17 00:00:00 2001
From: Alexey Shvetsov <alexxy@gentoo.org>
Date: Sat, 3 Aug 2019 23:14:09 +0300
Subject: sci-libs/scikits: Works with py3.7

Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
---
 sci-libs/scikits/scikits-0.1-r2.ebuild | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
 create mode 100644 sci-libs/scikits/scikits-0.1-r2.ebuild

(limited to 'sci-libs/scikits')

diff --git a/sci-libs/scikits/scikits-0.1-r2.ebuild b/sci-libs/scikits/scikits-0.1-r2.ebuild
new file mode 100644
index 000000000000..0febd354ddb8
--- /dev/null
+++ b/sci-libs/scikits/scikits-0.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit python-r1
+
+DESCRIPTION="Common files for python scikits"
+HOMEPAGE="http://projects.scipy.org/scipy/scikits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}.example/${PN}.example-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+	python_moduleinto scikits
+	python_foreach_impl python_domodule scikits.example*/scikits/__init__.py
+
+	if use examples; then
+		insinto /usr/share/doc/${PF}/examples
+		doins -r scikits.example*/*
+	fi
+}
-- 
cgit v1.2.3-65-gdbad