summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-07 01:20:08 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-07 01:20:08 +0000
commit01fc7947504fa9d180ec6ba0ef74442e8ea89764 (patch)
tree45da6d1187c015e9c7a5509facce7fdaaada3390 /app-admin/petrovich
parentadded virtual use x11-libs/xaw -> /x11-libs/Xaw3d (diff)
downloadhistorical-01fc7947504fa9d180ec6ba0ef74442e8ea89764.tar.gz
historical-01fc7947504fa9d180ec6ba0ef74442e8ea89764.tar.bz2
historical-01fc7947504fa9d180ec6ba0ef74442e8ea89764.zip
petrovich - a file integrity checker
Diffstat (limited to 'app-admin/petrovich')
-rw-r--r--app-admin/petrovich/files/petrovich-1.0.0-gentoo.diff32
-rw-r--r--app-admin/petrovich/files/petrovich.conf6
-rw-r--r--app-admin/petrovich/petrovich-1.0.0.ebuild34
3 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/petrovich/files/petrovich-1.0.0-gentoo.diff b/app-admin/petrovich/files/petrovich-1.0.0-gentoo.diff
new file mode 100644
index 000000000000..de193296fdf1
--- /dev/null
+++ b/app-admin/petrovich/files/petrovich-1.0.0-gentoo.diff
@@ -0,0 +1,32 @@
+diff -r -C2 petrovich.orig/petrovich.pl petrovich/petrovich.pl
+*** petrovich.orig/petrovich.pl Mon Jul 16 12:34:55 2001
+--- petrovich/petrovich.pl Sun Aug 5 22:22:54 2001
+***************
+*** 278,285 ****
+
+ # undef $db_hash_verifier; # for now cuz it's not working
+! $config_file = "petrovich.conf" unless defined($config_file);
+ $hash_type = "md5" unless defined($hash_type);
+ @stuff = ("filename", "mode","uid","gid","size","mtime","ctime","$hash_type");
+! $db_file = "petrovich.db" unless defined($db_file);
+
+ # if running under windows lowercase everything
+--- 278,285 ----
+
+ # undef $db_hash_verifier; # for now cuz it's not working
+! $config_file = "/etc/petrovich.conf" unless defined($config_file);
+ $hash_type = "md5" unless defined($hash_type);
+ @stuff = ("filename", "mode","uid","gid","size","mtime","ctime","$hash_type");
+! $db_file = "/var/db/petrovich/petrovich.db" unless defined($db_file);
+
+ # if running under windows lowercase everything
+***************
+*** 324,326 ****
+ }
+
+! }
+\ No newline at end of file
+--- 324,326 ----
+ }
+
+! }
diff --git a/app-admin/petrovich/files/petrovich.conf b/app-admin/petrovich/files/petrovich.conf
new file mode 100644
index 000000000000..03da7c1535fa
--- /dev/null
+++ b/app-admin/petrovich/files/petrovich.conf
@@ -0,0 +1,6 @@
+# petrovich.conf
+# to include directories to be checked include a line like the following:
+# +/sbin
+#
+# to exclude directories
+# -/var
diff --git a/app-admin/petrovich/petrovich-1.0.0.ebuild b/app-admin/petrovich/petrovich-1.0.0.ebuild
new file mode 100644
index 000000000000..7375dc3777d6
--- /dev/null
+++ b/app-admin/petrovich/petrovich-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Chad Huneycutt <chad.huneycutt@acm.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/petrovich/petrovich-1.0.0.ebuild,v 1.1 2001/08/07 01:20:08 chadh Exp $
+
+S=${WORKDIR}/petrovich
+DESCRIPTION="Filesystem Integrity Checker"
+SRC_URI="http://prdownloads.sf.net/petrovich/${PF}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/petrovich"
+
+#build-time dependencies
+DEPEND="sys-devel/perl"
+
+#run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+src_unpack () {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_install () {
+ into /usr
+ dosbin petrovich.pl
+
+ insinto /etc
+ doins ${FILESDIR}/petrovich.conf
+
+ dodir /var/db/petrovich
+
+ dodoc CHANGES.HTML LICENSE.HTML README.HTML TODO.HTML USAGE.HTML
+}
+